summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-12-04 18:36:26 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-12-04 18:36:26 +0000
commit994e5f222d06ad34b400bb07d0940d55c5d3335f (patch)
tree56477f24cc0e6b8c19993ec904c0bb12f1b1b2c5 /dev-vcs/git-annex
parentold (diff)
downloadhistorical-994e5f222d06ad34b400bb07d0940d55c5d3335f.tar.gz
historical-994e5f222d06ad34b400bb07d0940d55c5d3335f.tar.bz2
historical-994e5f222d06ad34b400bb07d0940d55c5d3335f.zip
Initial version. manage files with git, without checking their contents into git. (requested in bug #343563 by Christoph Junghans)
Package-Manager: portage-2.2.0_alpha77_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-vcs/git-annex')
-rw-r--r--dev-vcs/git-annex/ChangeLog11
-rw-r--r--dev-vcs/git-annex/Manifest14
-rw-r--r--dev-vcs/git-annex/git-annex-3.20111203.ebuild37
-rw-r--r--dev-vcs/git-annex/metadata.xml22
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-vcs/git-annex/ChangeLog b/dev-vcs/git-annex/ChangeLog
new file mode 100644
index 000000000000..1132d27af989
--- /dev/null
+++ b/dev-vcs/git-annex/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-vcs/git-annex
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/ChangeLog,v 1.1 2011/12/04 18:36:26 slyfox Exp $
+
+*git-annex-3.20111203 (04 Dec 2011)
+
+ 04 Dec 2011; Sergei Trofimovich <slyfox@gentoo.org>
+ +git-annex-3.20111203.ebuild, +metadata.xml:
+ Initial version. manage files with git, without checking their contents into
+ git. (requested in bug #343563 by Christoph Junghans)
+
diff --git a/dev-vcs/git-annex/Manifest b/dev-vcs/git-annex/Manifest
new file mode 100644
index 000000000000..94af3b884b49
--- /dev/null
+++ b/dev-vcs/git-annex/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST git-annex-3.20111203.tar.gz 442974 RMD160 b5f06d6cbffc3cab1dca5f53f2b41ef748ae6d26 SHA1 3aea68b9e00fdfcc08d6f55f7879e21b6d4844df SHA256 3b7361c9d27302f23136266ff1223b2a82c280988b3c706d518539eb577af244
+EBUILD git-annex-3.20111203.ebuild 982 RMD160 0d2bfb9cb9f29ab76234a0da7a01671f105cdbb0 SHA1 af2a6d5a5700d163b3080863feb498f636c2c887 SHA256 e302c17324308e46a0e7b958aea35acd2829f7cc98204d964d094920ebbe6822
+MISC ChangeLog 481 RMD160 8665f0b7f114b2ecda783106955a37daf9e3b648 SHA1 adfe886fafa6690e8da0f0af0b159c4ce51ac9aa SHA256 b0d8545a73e6f03821a00822c0312fb69961dea92d5c74cac65d7f2aa71b0b4a
+MISC metadata.xml 1020 RMD160 81b37c15cbdd25d6dcb65d45e5ba706c8674d6c7 SHA1 4d4ea625f0309ea23886699dc3c0a0b556d8f89f SHA256 adb6331810d079ace08d3df7e88a56839b86d9656b42a6212f641a462d34b4c3
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk7bvqEACgkQcaHudmEf86o3rACfRE9kuy5q30TM/H+9jIsXOQ5n
+/d4Anj2htIAP4QF7Vey9Bzn/gg7iSl1Q
+=dH7P
+-----END PGP SIGNATURE-----
diff --git a/dev-vcs/git-annex/git-annex-3.20111203.ebuild b/dev-vcs/git-annex/git-annex-3.20111203.ebuild
new file mode 100644
index 000000000000..043cae25688d
--- /dev/null
+++ b/dev-vcs/git-annex/git-annex-3.20111203.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-annex/git-annex-3.20111203.ebuild,v 1.1 2011/12/04 18:36:26 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal
+
+DESCRIPTION="manage files with git, without checking their contents into git"
+HOMEPAGE="http://git-annex.branchable.com/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/git-1.7.7" # TODO: add more deps?
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ dev-haskell/dataenc
+ dev-haskell/hs3
+ dev-haskell/hslogger
+ dev-haskell/http
+ dev-haskell/json
+ dev-haskell/missingh
+ dev-haskell/monad-control
+ dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/pcre-light
+ dev-haskell/sha
+ dev-haskell/time
+ dev-haskell/utf8-string
+ >=dev-lang/ghc-6.10.1"
diff --git a/dev-vcs/git-annex/metadata.xml b/dev-vcs/git-annex/metadata.xml
new file mode 100644
index 000000000000..19222bedf181
--- /dev/null
+++ b/dev-vcs/git-annex/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ git-annex allows managing files with git, without checking the file
+ contents into git. While that may seem paradoxical, it is useful when
+ dealing with files larger than git can currently easily handle, whether due
+ to limitations in memory, checksumming time, or disk space.
+
+ Even without file content tracking, being able to manage files with git,
+ move files around and delete files with versioned directory trees, and use
+ branches and distributed clones, are all very handy reasons to use git. And
+ annexed files can co-exist in the same git repository with regularly
+ versioned files, which is convenient for maintaining documents, Makefiles,
+ etc that are associated with annexed files but that benefit from full
+ revision control.
+ </longdescription>
+</pkgmetadata>