summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-10 11:39:42 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-10 11:39:42 +0000
commit852d15b924f623e8ea2c901cb78d9941c36e5ef7 (patch)
treeb3b971d217bd4c5a0e7aab9b1f88bf2ffad2c342 /eclass/distutils-r1.eclass
parentError out if "tests" package is installed. This is a common mistake and a sou... (diff)
downloadhistorical-852d15b924f623e8ea2c901cb78d9941c36e5ef7.tar.gz
historical-852d15b924f623e8ea2c901cb78d9941c36e5ef7.tar.bz2
historical-852d15b924f623e8ea2c901cb78d9941c36e5ef7.zip
Override egg-info write location in out-of-source builds.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass9
1 files changed, 8 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 043fe1b0c2da..ec7171b8a624 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.49 2013/02/10 11:38:17 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.50 2013/02/10 11:39:42 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -215,6 +215,13 @@ esetup.py() {
die 'Out-of-source build requested, yet BUILD_DIR unset.'
fi
+ # if setuptools is used, adjust egg_info path as well
+ if "${PYTHON:-python}" setup.py --help egg_info &>/dev/null; then
+ add_args+=(
+ egg_info --egg-base "${BUILD_DIR}"
+ )
+ fi
+
add_args+=(
build
--build-base "${BUILD_DIR}"