summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-01 10:52:40 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-01 10:52:40 +0000
commitb7adeda57dd74f3a41946180f08e2ef26240d7e2 (patch)
tree25be7f90b62b78e19a7fce13f73cf798ab11bf28 /eclass/distutils-r1.eclass
parentMake distutils-r1_rename_scripts private. Rename all matching executables rec... (diff)
downloadhistorical-b7adeda57dd74f3a41946180f08e2ef26240d7e2.tar.gz
historical-b7adeda57dd74f3a41946180f08e2ef26240d7e2.tar.bz2
historical-b7adeda57dd74f3a41946180f08e2ef26240d7e2.zip
Use intermediate-root install.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass11
1 files changed, 8 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 128dcc14a196..f0b250284313 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.21 2012/12/01 10:51:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.22 2012/12/01 10:52:40 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -297,9 +297,14 @@ distutils-r1_python_install() {
local PYTHONDONTWRITEBYTECODE
export PYTHONDONTWRITEBYTECODE
- esetup.py install "${flags[@]}" --root="${D}" "${@}"
+ local root=${D}/_${EPYTHON}
- _distutils-r1_rename_scripts "${D}"
+ esetup.py install "${flags[@]}" --root="${root}" "${@}"
+ _distutils-r1_rename_scripts "${root}"
+
+ # merge
+ cp -a -l -n "${root}"/* "${D}"/ || die "Merging ${EPYTHON} image failed."
+ rm -rf "${root}"
}
# @FUNCTION: distutils-r1_python_install_all