summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-22 14:16:03 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-22 14:16:03 +0000
commit80deb9558416d3477d378b72cb14724920b0cd3a (patch)
treeff15e6aae10b4aec5cc22dba501dd518c1637d79 /eclass/freebsd.eclass
parentStable for ia64, wrt bug #530652 (diff)
downloadhistorical-80deb9558416d3477d378b72cb14724920b0cd3a.tar.gz
historical-80deb9558416d3477d378b72cb14724920b0cd3a.tar.bz2
historical-80deb9558416d3477d378b72cb14724920b0cd3a.zip
Fix support for FreeBSD 10.0. Force /usr/share/mk there, and fix version comparison for install commands. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/36 by nigoro.
Diffstat (limited to 'eclass/freebsd.eclass')
-rw-r--r--eclass/freebsd.eclass12
1 files changed, 9 insertions, 3 deletions
diff --git a/eclass/freebsd.eclass b/eclass/freebsd.eclass
index f293e4b4ef98..d708b4b266fd 100644
--- a/eclass/freebsd.eclass
+++ b/eclass/freebsd.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/freebsd.eclass,v 1.35 2013/08/28 15:56:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/freebsd.eclass,v 1.36 2015/02/22 14:16:03 mgorny Exp $
#
# Diego Pettenò <flameeyes@gentoo.org>
@@ -129,6 +129,12 @@ freebsd_rename_libraries() {
freebsd_src_unpack() {
if [[ ${MY_PV} == *9999* ]]; then
S="${WORKDIR}" subversion_src_unpack
+
+ # When share/mk exists in ${WORKDIR}, it is used on FreeBSD 10.0
+ # Removed "${WORKDIR}"/share/mk/*.mk, use to force /usr/share/mk.
+ if [[ ${PN} != freebsd-mk-defs ]] ; then
+ [[ -e "${WORKDIR}"/share/mk ]] && rm -rf "${WORKDIR}"/share/mk/*.mk
+ fi
else
unpack ${A}
fi
@@ -141,7 +147,7 @@ freebsd_src_unpack() {
# Starting from FreeBSD 9.2, its install command supports the -l option and
# they now use it. Emulate it if we are on a system that does not have it.
- if [[ ${RV} > 9.1 ]] && ! has_version '>=sys-freebsd/freebsd-ubin-9.2_beta1' ; then
+ if version_is_at_least 9.2 ${RV} && ! has_version '>=sys-freebsd/freebsd-ubin-9.2_beta1' ; then
export INSTALL_LINK="ln -f"
export INSTALL_SYMLINK="ln -fs"
fi