summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-04-03 11:16:52 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-04-03 11:16:52 +0000
commit1aaec00a6b9eb982a2042a0bd4b212cf75f2d87b (patch)
tree7c99db1224e078660ddd929c3794ce859a9d7eff /eclass
parentversion bump (diff)
downloadhistorical-1aaec00a6b9eb982a2042a0bd4b212cf75f2d87b.tar.gz
historical-1aaec00a6b9eb982a2042a0bd4b212cf75f2d87b.tar.bz2
historical-1aaec00a6b9eb982a2042a0bd4b212cf75f2d87b.zip
Corrected checks for Makefile.PL and Build.PL, closes bug 128487
Diffstat (limited to 'eclass')
-rw-r--r--eclass/perl-app.eclass8
-rw-r--r--eclass/perl-module.eclass8
2 files changed, 8 insertions, 8 deletions
diff --git a/eclass/perl-app.eclass b/eclass/perl-app.eclass
index c8ced4b76f16..e94d099d304d 100644
--- a/eclass/perl-app.eclass
+++ b/eclass/perl-app.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/perl-app.eclass,v 1.2 2006/04/01 15:58:29 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/perl-app.eclass,v 1.3 2006/04/03 11:16:52 mcummings Exp $
#
# Author: Michael Cummings <mcummings@gentoo.org>
@@ -23,12 +23,12 @@ perl-app_src_prep() {
SRC_PREP="yes"
- if [ -f ${S}/Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
einfo "Using ExtUtils::MakeMaker"
#perl Makefile.PL ${myconf} \
perl Makefile.PL ${myconf} INSTALLMAN3DIR='none'\
PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}
- elif [ -f ${S}/Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
+ elif [ -f Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
einfo "Using Module::Build"
if [ -z ${BUILDER_VER} ]; then
eerror
@@ -39,7 +39,7 @@ perl-app_src_prep() {
eerror
die
else
- perl ${S}/Build.PL installdirs=vendor destdir=${D}
+ perl Build.PL installdirs=vendor destdir=${D}
fi
else
einfo "No Make or Build file detect..."
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index f85a3584a962..07e86500a0b8 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.85 2006/04/01 15:58:29 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v 1.86 2006/04/03 11:16:52 mcummings Exp $
#
# Author: Seemant Kulleen <seemant@gentoo.org>
# Maintained by the Perl herd <perl@gentoo.org>
@@ -95,12 +95,12 @@ perl-module_src_prep() {
SRC_PREP="yes"
- if [ -f ${S}/Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
einfo "Using ExtUtils::MakeMaker"
#perl Makefile.PL ${myconf} \
perl Makefile.PL ${myconf} INSTALLMAN3DIR='none'\
PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}
- elif [ -f ${S}/Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
+ elif [ -f Build.PL ] && [ "${USE_BUILDER}" == "yes" ]; then
einfo "Using Module::Build"
if [ -z ${BUILDER_VER} ]; then
eerror
@@ -111,7 +111,7 @@ perl-module_src_prep() {
eerror
die
else
- perl ${S}/Build.PL installdirs=vendor destdir=${D} libdoc=
+ perl Build.PL installdirs=vendor destdir=${D} libdoc=
fi
else
einfo "No Make or Build file detect..."