summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-08-18 02:48:43 +0000
committerJim Ramsay <lack@gentoo.org>2011-08-18 02:48:43 +0000
commitd3d90eb2b8162f843777ede01011edfb063ed1fc (patch)
tree212cd4f5c13166b7786a4ef0893b9c07d4f1c399 /eclass
parentVersion bump; Add patch to drop cmake 2.6.x compatible statement (diff)
downloadhistorical-d3d90eb2b8162f843777ede01011edfb063ed1fc.tar.gz
historical-d3d90eb2b8162f843777ede01011edfb063ed1fc.tar.bz2
historical-d3d90eb2b8162f843777ede01011edfb063ed1fc.zip
Bug #378107: Build with >=perl-core/ExtUtils-ParseXS-3.20.0
This just takes the patches from the above build and rolls a single sed line into the eclass instead.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vim.eclass8
1 files changed, 7 insertions, 1 deletions
diff --git a/eclass/vim.eclass b/eclass/vim.eclass
index e33505e533b0..4e8df6e6f814 100644
--- a/eclass/vim.eclass
+++ b/eclass/vim.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.198 2011/07/13 04:22:33 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.199 2011/08/18 02:48:43 lack Exp $
# Authors:
# Jim Ramsay <lack@gentoo.org>
@@ -356,6 +356,12 @@ END
if version_is_at_least 7.3.122; then
cp "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk
fi
+
+ # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
+ if version_is_at_least 7.3; then
+ sed -i 's:\$(PERLLIB)/ExtUtils/xsubpp:/usr/bin/xsubpp:' \
+ "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+ fi
}
vim_src_unpack() {