summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-14 22:57:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-14 22:57:09 +0000
commite76f7526909c8f795730519389781d9bb8818545 (patch)
treef3796e9559090503d9f5bb7bd35a6feceafc307f /eclass
parentremoving quota entry from conf.d (diff)
downloadhistorical-e76f7526909c8f795730519389781d9bb8818545.tar.gz
historical-e76f7526909c8f795730519389781d9bb8818545.tar.bz2
historical-e76f7526909c8f795730519389781d9bb8818545.zip
fix bug 37354: Disallow -funroll-all-loops on amd64
Diffstat (limited to 'eclass')
-rw-r--r--eclass/vim.eclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/eclass/vim.eclass b/eclass/vim.eclass
index cd999dee212b..58a539f436fd 100644
--- a/eclass/vim.eclass
+++ b/eclass/vim.eclass
@@ -1,13 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.47 2004/01/06 16:01:57 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/vim.eclass,v 1.48 2004/01/14 22:57:09 agriffis Exp $
# Authors:
# Ryan Phillips <rphillips@gentoo.org>
# Seemant Kulleen <seemant@gentoo.org>
# Aron Griffis <agriffis@gentoo.org>
-inherit eutils vim-doc
+inherit eutils vim-doc flag-o-matic
ECLASS=vim
INHERITED="$INHERITED $ECLASS"
EXPORT_FUNCTIONS src_unpack
@@ -160,7 +160,10 @@ vim_src_unpack() {
src_compile() {
local myconf confrule
- # Fix bug #18245: Prevent "make" from the following chain:
+ # Fix bug 37354: Disallow -funroll-all-loops on amd64
+ [[ $ARCH == amd64 ]] && filter-flags -funroll-all-loops
+
+ # Fix bug 18245: Prevent "make" from the following chain:
# (1) Notice configure.in is newer than auto/configure
# (2) Rebuild auto/configure
# (3) Notice auto/configure is newer than auto/config.mk