summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:16 +0000
commit6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3 (patch)
tree5578c0bf4dcb7768e6bc8e22c99c359d60cb6c8e /games-action/dungeon/dungeon-3.2.3.ebuild
parentgames action and arcade (diff)
downloadhistorical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.gz
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.tar.bz2
historical-6b2c6aa5f4161d5fcd009e3e5f2e9d84539b25f3.zip
action games !
Diffstat (limited to 'games-action/dungeon/dungeon-3.2.3.ebuild')
-rw-r--r--games-action/dungeon/dungeon-3.2.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-action/dungeon/dungeon-3.2.3.ebuild b/games-action/dungeon/dungeon-3.2.3.ebuild
new file mode 100644
index 000000000000..170c43a14d2a
--- /dev/null
+++ b/games-action/dungeon/dungeon-3.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="A linux port of the Dungeon game once distributed by DECUS"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/dungeon-3.2.3.html"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/games/textrpg/${P}.src.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="dev-lang/f2c
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/dungn32c"
+
+DATS="${GAMES_DATADIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:-O:${CFLAGS}:g" Makefile || die "sed Makefile failed"
+}
+
+src_compile() {
+ make game.c || die "make game.c failed"
+ sed -i \
+ -re "s:d(indx|text).dat:${DATS}/&:g" \
+ -e "s:ofnmlen = [^;]+:&+${#DATS}+1:g" \
+ game.c || die "sed game.c failed"
+
+ emake || die
+}
+
+src_install() {
+ dogamesbin dungeon
+ insinto ${DATS}
+ doins dindx.dat dtext.dat
+ doman ${FILESDIR}/dungeon.6
+ dodoc README *.txt *.doc
+ prepgamesdirs
+}