summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-04 21:32:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-04 21:32:20 +0000
commitb21de5c416fb6604e26c1002606e9a32d9fb168a (patch)
tree613622feb4c46e0d9a14991b2d6e83945801c013 /games-action/garden/files
parentadd patch from zimous to fix building with gcc49 (bug #538580) (diff)
downloadhistorical-b21de5c416fb6604e26c1002606e9a32d9fb168a.tar.gz
historical-b21de5c416fb6604e26c1002606e9a32d9fb168a.tar.bz2
historical-b21de5c416fb6604e26c1002606e9a32d9fb168a.zip
version bump
Package-Manager: portage-2.2.18/cvs/Linux x86_64
Diffstat (limited to 'games-action/garden/files')
-rw-r--r--games-action/garden/files/garden-1.0.8-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.9-dash.patch33
-rw-r--r--games-action/garden/files/garden-1.0.9-resources.patch7
3 files changed, 73 insertions, 0 deletions
diff --git a/games-action/garden/files/garden-1.0.8-dash.patch b/games-action/garden/files/garden-1.0.8-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.9-dash.patch b/games-action/garden/files/garden-1.0.9-dash.patch
new file mode 100644
index 000000000000..2d8630236ffb
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-dash.patch
@@ -0,0 +1,33 @@
+--- configure.ac.orig 2015-05-04 14:48:03.467935640 -0400
++++ configure.ac 2015-05-04 14:48:24.729199607 -0400
+@@ -80,7 +80,7 @@
+ [have_allegro="no"])
+ AC_MSG_RESULT([$have_allegro])
+ LIBS=$LIBS_SAVE
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [return 0],
+ [return 1])
+ }
+@@ -89,7 +89,7 @@
+ AM_PATH_ALLEGRO([4.2.0])
+
+ try_link_allegro "$allegro_LIBS"
+-AS_IF([test "x$?" == "x0"],
++AS_IF([test "x$?" = "x0"],
+ [[LIBS="$LIBS $allegro_LIBS"
+ ALLEGRO_LIB=`echo $allegro_LIBS | sed -e 's/-l\([^[:blank:]]*\).*/\1/'`
+ have_allegro="yes"]])
+@@ -103,10 +103,10 @@
+ for lib in $ALLEGRO_LIBS
+ do
+ ldflag="-l$lib"
+- AS_IF([test "x$have_allegro" == "xyes"],
++ AS_IF([test "x$have_allegro" = "xyes"],
+ [break])
+ try_link_allegro $ldflag
+- AS_IF([test "x$?" == "x0"],
++ AS_IF([test "x$?" = "x0"],
+ [LIBS="$LIBS $ldflag"
+ ALLEGRO_LIB="$lib"
+ have_allegro="yes"])
diff --git a/games-action/garden/files/garden-1.0.9-resources.patch b/games-action/garden/files/garden-1.0.9-resources.patch
new file mode 100644
index 000000000000..6acd6f5f78d5
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-resources.patch
@@ -0,0 +1,7 @@
+--- Makefile.am.orig 2015-05-04 16:57:07.510191036 -0400
++++ Makefile.am 2015-05-04 16:57:14.581946228 -0400
+@@ -1,3 +1,3 @@
+ ACLOCAL_AMFLAGS= -I m4
+
+-SUBDIRS = src resources data
++SUBDIRS = src data