summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commit2d06451b949706e2e14d1e9cdbdedf30613ca779 (patch)
treee4defbc5a7848f65ff263eb968fe9f97f4e1a5f1 /games-arcade/solarwolf
parentaction games ! (diff)
downloadhistorical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.gz
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.tar.bz2
historical-2d06451b949706e2e14d1e9cdbdedf30613ca779.zip
arcade games !
Diffstat (limited to 'games-arcade/solarwolf')
-rw-r--r--games-arcade/solarwolf/ChangeLog13
-rw-r--r--games-arcade/solarwolf/Manifest6
-rw-r--r--games-arcade/solarwolf/files/digest-solarwolf-1.11
-rw-r--r--games-arcade/solarwolf/files/digest-solarwolf-1.21
-rw-r--r--games-arcade/solarwolf/files/solarwolf3
-rw-r--r--games-arcade/solarwolf/solarwolf-1.1.ebuild27
-rw-r--r--games-arcade/solarwolf/solarwolf-1.2.ebuild27
7 files changed, 78 insertions, 0 deletions
diff --git a/games-arcade/solarwolf/ChangeLog b/games-arcade/solarwolf/ChangeLog
new file mode 100644
index 000000000000..11694834961a
--- /dev/null
+++ b/games-arcade/solarwolf/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-games/solarwolf
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/ChangeLog,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+*solarwolf-1.2 (03 Aug 2003)
+
+ 03 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
+
+*solarwolf-1.1 (13 Jul 2003)
+
+ 13 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-arcade/solarwolf/Manifest b/games-arcade/solarwolf/Manifest
new file mode 100644
index 000000000000..08a7b7f7ebc4
--- /dev/null
+++ b/games-arcade/solarwolf/Manifest
@@ -0,0 +1,6 @@
+MD5 73ae686ccf115da6b627903e47887ed2 solarwolf-1.1.ebuild 759
+MD5 e25d8163052acb0586f8b4a69915cd4a files/digest-solarwolf-1.1 65
+MD5 a42a132d2de34b2827ce023e4849ef03 files/solarwolf 56
+MD5 6d05033c952f85d8c73d7e5b9952fd4c files/digest-solarwolf-1.2 65
+MD5 3b1ce3f67f0b831a74b819b295b3da7c ChangeLog 444
+MD5 1ed02e9725590e60af877e961839f974 solarwolf-1.2.ebuild 759
diff --git a/games-arcade/solarwolf/files/digest-solarwolf-1.1 b/games-arcade/solarwolf/files/digest-solarwolf-1.1
new file mode 100644
index 000000000000..a39674dc195f
--- /dev/null
+++ b/games-arcade/solarwolf/files/digest-solarwolf-1.1
@@ -0,0 +1 @@
+MD5 7c848d66d27569a54d263af2a252ab93 solarwolf-1.1.tar.gz 972202
diff --git a/games-arcade/solarwolf/files/digest-solarwolf-1.2 b/games-arcade/solarwolf/files/digest-solarwolf-1.2
new file mode 100644
index 000000000000..4da14b5021e2
--- /dev/null
+++ b/games-arcade/solarwolf/files/digest-solarwolf-1.2
@@ -0,0 +1 @@
+MD5 d82f6eb25c0937749f62ff70b49e60a0 solarwolf-1.2.tar.gz 998249
diff --git a/games-arcade/solarwolf/files/solarwolf b/games-arcade/solarwolf/files/solarwolf
new file mode 100644
index 000000000000..7f8d1c1049c4
--- /dev/null
+++ b/games-arcade/solarwolf/files/solarwolf
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd GENTOO_DIR
+exec python ./solarwolf.py ${@}
diff --git a/games-arcade/solarwolf/solarwolf-1.1.ebuild b/games-arcade/solarwolf/solarwolf-1.1.ebuild
new file mode 100644
index 000000000000..e28ac4271f19
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.1.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games
+
+DESCRIPTION="action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-python/pygame
+ dev-lang/python
+ media-libs/libsdl"
+
+src_install() {
+ dodoc readme.txt
+ rm *.txt
+ dodir ${GAMES_LIBDIR}/${PN}
+ cp -r * ${D}/${GAMES_LIBDIR}/${PN}/
+ dogamesbin ${FILESDIR}/solarwolf
+ dosed "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/solarwolf
+ prepgamesdirs
+}
diff --git a/games-arcade/solarwolf/solarwolf-1.2.ebuild b/games-arcade/solarwolf/solarwolf-1.2.ebuild
new file mode 100644
index 000000000000..3171e3f10b1c
--- /dev/null
+++ b/games-arcade/solarwolf/solarwolf-1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.2.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games
+
+DESCRIPTION="action/arcade recreation of SolarFox"
+HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
+SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-python/pygame
+ dev-lang/python
+ media-libs/libsdl"
+
+src_install() {
+ dodoc readme.txt
+ rm *.txt
+ dodir ${GAMES_LIBDIR}/${PN}
+ cp -r * ${D}/${GAMES_LIBDIR}/${PN}/
+ dogamesbin ${FILESDIR}/solarwolf
+ dosed "s:GENTOO_DIR:${GAMES_LIBDIR}/${PN}:" ${GAMES_BINDIR}/solarwolf
+ prepgamesdirs
+}