summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 17:46:27 +0000
commitfb8c4cf310fc6a66ecddbe48c1b77a183baa6141 (patch)
tree179b6d7697d589a3888e34ab007a4d76082e89ee /games-board/xfrisk/xfrisk-1.2.ebuild
parentChanges to make the eclass more flexible (diff)
downloadhistorical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.gz
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.tar.bz2
historical-fb8c4cf310fc6a66ecddbe48c1b77a183baa6141.zip
board board games
Diffstat (limited to 'games-board/xfrisk/xfrisk-1.2.ebuild')
-rw-r--r--games-board/xfrisk/xfrisk-1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-board/xfrisk/xfrisk-1.2.ebuild b/games-board/xfrisk/xfrisk-1.2.ebuild
new file mode 100644
index 000000000000..a81c945a1601
--- /dev/null
+++ b/games-board/xfrisk/xfrisk-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xfrisk/xfrisk-1.2.ebuild,v 1.1 2003/09/10 17:46:27 vapier Exp $
+
+inherit games
+
+S=${WORKDIR}/XFrisk
+DESCRIPTION="The RISK board game"
+SRC_URI="http://morphy.iki.fi/xfrisk/files/${P}.tar.gz"
+HOMEPAGE="http://morphy.iki.fi/xfrisk/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="x11-libs/Xaw3d
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:/usr/local:${GAMES_PREFIX}:" \
+ Makefile || \
+ die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make PREFIX=${D}/${GAMES_PREFIX} install || die "make install failed"
+ dodoc BUGS ChangeLog FAQ TODO
+ prepgamesdirs
+}