summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-22 07:13:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-22 07:13:41 +0000
commit973e284a6a5278ec89bf3b126e9a032460b29dac (patch)
tree4c24856f3f19eea3672e47661cf4e9db05b2d39a /games-board/xmille/xmille-2.0-r1.ebuild
parentVersion bump closes bug #48646. Ebuild cleanup. USE=esd support. (diff)
downloadhistorical-973e284a6a5278ec89bf3b126e9a032460b29dac.tar.gz
historical-973e284a6a5278ec89bf3b126e9a032460b29dac.tar.bz2
historical-973e284a6a5278ec89bf3b126e9a032460b29dac.zip
get the patch off the Debian mirrors; update to the latest Debian patch.
Diffstat (limited to 'games-board/xmille/xmille-2.0-r1.ebuild')
-rw-r--r--games-board/xmille/xmille-2.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-board/xmille/xmille-2.0-r1.ebuild b/games-board/xmille/xmille-2.0-r1.ebuild
new file mode 100644
index 000000000000..9c576254c498
--- /dev/null
+++ b/games-board/xmille/xmille-2.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xmille/xmille-2.0-r1.ebuild,v 1.1 2004/04/22 07:13:41 mr_bones_ Exp $
+
+inherit eutils games
+
+DEB_PATCH_VER="10"
+DESCRIPTION="Mille Bournes card game"
+HOMEPAGE=""
+SRC_URI="mirror://debian/pool/main/x/xmille/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/xmille/${PN}_${PV}-${DEB_PATCH_VER}.diff.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+S="${WORKDIR}/${PN}-${PV}.orig"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${WORKDIR}/${PN}_${PV}-${DEB_PATCH_VER}.diff"
+}
+
+src_compile() {
+ xmkmf
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dogamesbin xmille || die "dogamesbin failed"
+ dodoc CHANGES README
+ newman xmille.man xmille.6
+ prepgamesdirs
+}