summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-01-24 00:58:28 +0000
committerDon Seiler <rizzo@gentoo.org>2005-01-24 00:58:28 +0000
commite51e6108a3958b4a778466335d178c4aa4e73a96 (patch)
treeff8f7c04bda9e2cfdbf4f5de8aa99f48f5c4da9e /games-board
parentActually fix bug 78726 this time. (diff)
downloadhistorical-e51e6108a3958b4a778466335d178c4aa4e73a96.tar.gz
historical-e51e6108a3958b4a778466335d178c4aa4e73a96.tar.bz2
historical-e51e6108a3958b4a778466335d178c4aa4e73a96.zip
Version bump
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest4
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.501
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.50.ebuild45
4 files changed, 55 insertions, 2 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index 59eaa9f1c478..9058431b88ca 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.26 2005/01/10 02:01:48 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.27 2005/01/24 00:58:28 rizzo Exp $
+
+*gnocatan-0.8.1.50 (23 Jan 2005)
+
+ 23 Jan 2005; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.50.ebuild:
+ Version bump
*gnocatan-0.8.1.48 (09 Jan 2005)
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index bd2a286650e4..e3cd981392a4 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -1,6 +1,8 @@
-MD5 10aa5fc5cbe6724dfe650c7745b293e0 ChangeLog 4804
+MD5 7e639ac08da3e4061f097605580e9146 ChangeLog 4926
MD5 6c981cc28287184d6af61ae723f719f0 gnocatan-0.8.1.48.ebuild 1072
MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
+MD5 050dd14fa324acf263d2b9efaf4ecf87 gnocatan-0.8.1.50.ebuild 1072
MD5 4c72a30b035261035ab345f7dc59d659 gnocatan-0.8.1.45.ebuild 1071
MD5 8a440d112b6916e3a030de1638cfacaa files/digest-gnocatan-0.8.1.48 70
+MD5 7f5d904ae59b3a0b720f638f62c5a211 files/digest-gnocatan-0.8.1.50 70
MD5 353926677e5af852d2ce1cf9d8baa74e files/digest-gnocatan-0.8.1.45 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.50 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.50
new file mode 100644
index 000000000000..e7d92a62a45e
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.50
@@ -0,0 +1 @@
+MD5 74974197bf40bddc5778afea30d52d23 gnocatan-0.8.1.50.tar.gz 2064147
diff --git a/games-board/gnocatan/gnocatan-0.8.1.50.ebuild b/games-board/gnocatan/gnocatan-0.8.1.50.ebuild
new file mode 100644
index 000000000000..5bdcf416010c
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.50.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.50.ebuild,v 1.1 2005/01/24 00:58:28 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls debug X"
+
+RDEPEND="dev-libs/glib
+ dev-util/pkgconfig
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}