summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-27 23:03:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-27 23:03:02 +0000
commitf4c490c04755b71814f2c2edeb8b9d41696307bd (patch)
treef0382d800e587d7d13ad3d7ae22944f1574c62a6 /games-emulation/dosbox/dosbox-0.73.ebuild
parentFix src_test and don't use deprecated modules in python >= 2.5. Fixes bug #24... (diff)
downloadhistorical-f4c490c04755b71814f2c2edeb8b9d41696307bd.tar.gz
historical-f4c490c04755b71814f2c2edeb8b9d41696307bd.tar.bz2
historical-f4c490c04755b71814f2c2edeb8b9d41696307bd.zip
version bump
Package-Manager: portage-2.1.6.11/cvs/Linux i686
Diffstat (limited to 'games-emulation/dosbox/dosbox-0.73.ebuild')
-rw-r--r--games-emulation/dosbox/dosbox-0.73.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-emulation/dosbox/dosbox-0.73.ebuild b/games-emulation/dosbox/dosbox-0.73.ebuild
new file mode 100644
index 000000000000..68b7363bc9cb
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.73.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.73.ebuild,v 1.1 2009/05/27 23:03:02 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib[midi] )
+ opengl? ( virtual/opengl )
+ debug? ( sys-libs/ncurses )
+ media-libs/libpng
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+ prepgamesdirs
+}