summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2004-08-15 10:31:55 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2004-08-15 10:31:55 +0000
commitd8eed37899d14c390f269466e68b89877cce633c (patch)
treefbe923080df6c40765196245a49c992220486858 /games-emulation/xmame/xmame-0.83.1.ebuild
parentMoved from net-www/horde-forwards to www-apps/horde-forwards (diff)
downloadhistorical-d8eed37899d14c390f269466e68b89877cce633c.tar.gz
historical-d8eed37899d14c390f269466e68b89877cce633c.tar.bz2
historical-d8eed37899d14c390f269466e68b89877cce633c.zip
Fixed a link-error on PowerPC.
Diffstat (limited to 'games-emulation/xmame/xmame-0.83.1.ebuild')
-rw-r--r--games-emulation/xmame/xmame-0.83.1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/games-emulation/xmame/xmame-0.83.1.ebuild b/games-emulation/xmame/xmame-0.83.1.ebuild
index 03af6aaf41c6..fa7163b295b9 100644
--- a/games-emulation/xmame/xmame-0.83.1.ebuild
+++ b/games-emulation/xmame/xmame-0.83.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.83.1.ebuild,v 1.3 2004/06/24 22:37:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.83.1.ebuild,v 1.4 2004/08/15 10:31:55 hansmi Exp $
inherit flag-o-matic gcc eutils games
@@ -73,10 +73,18 @@ src_unpack() {
|| die "sed Makefile (joystick) failed"
fi
;;
- ppc|sparc|hppa)
+ ppc)
sed -i \
-e '/^MY_CPU/s:i386:risc:' Makefile \
- || die "sed Makefile (ppc|sparc|hppa) failed"
+ || die "sed Makefile (ppc) failed"
+ sed -i \
+ -e '/^LD\t= $(CC) -Wl,-s/s:$: -Wl,--relax:' Makefile \
+ || die "sed Makefile (ppc) failed"
+ ;;
+ sparc|hppa)
+ sed -i \
+ -e '/^MY_CPU/s:i386:risc:' Makefile \
+ || die "sed Makefile (sparc|hppa) failed"
;;
alpha)
sed -i \