summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-28 00:59:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-28 00:59:08 +0000
commitd6b434c7f18871b775170096c599471b768a8510 (patch)
tree8b2e8cb1fb4f97b3138d1bd5a1a08b7dbc7d3fc4 /games-emulation
parentbump (diff)
downloadhistorical-d6b434c7f18871b775170096c599471b768a8510.tar.gz
historical-d6b434c7f18871b775170096c599471b768a8510.tar.bz2
historical-d6b434c7f18871b775170096c599471b768a8510.zip
add back in pic patch to try to fix bug #118836; fix up slang dep (bug #141947)
Package-Manager: portage-2.1.1_pre3-r5
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog6
-rw-r--r--games-emulation/advancemame/advancemame-0.106.0.ebuild5
-rw-r--r--games-emulation/advancemame/files/advancemame-0.106.0-pic.patch13
3 files changed, 21 insertions, 3 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index e7f268d1d49f..34a97488e70c 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.39 2006/07/27 21:20:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.40 2006/07/28 00:59:08 mr_bones_ Exp $
+
+ 28 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/advancemame-0.106.0-pic.patch, advancemame-0.106.0.ebuild:
+ add back in pic patch to try to fix bug #118836; fix up slang dep (bug #141947)
*advancemame-0.106.0 (27 Jul 2006)
diff --git a/games-emulation/advancemame/advancemame-0.106.0.ebuild b/games-emulation/advancemame/advancemame-0.106.0.ebuild
index 4ec3cfc5016e..ed5f631d698b 100644
--- a/games-emulation/advancemame/advancemame-0.106.0.ebuild
+++ b/games-emulation/advancemame/advancemame-0.106.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.1 2006/07/27 21:20:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.106.0.ebuild,v 1.2 2006/07/28 00:59:08 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -16,7 +16,7 @@ IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
RDEPEND="app-arch/unzip
app-arch/zip
sdl? ( media-libs/libsdl )
- slang? ( sys-libs/slang )
+ slang? ( =sys-libs/slang-1* )
alsa? ( media-libs/alsa-lib )
expat? ( >=dev-libs/expat-1.95.6 )
zlib? ( sys-libs/zlib )
@@ -30,6 +30,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-pic.patch"
sed -i \
-e 's/"-s"//' \
configure \
diff --git a/games-emulation/advancemame/files/advancemame-0.106.0-pic.patch b/games-emulation/advancemame/files/advancemame-0.106.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/advancemame-0.106.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"