summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-10-19 21:38:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-10-19 21:38:48 +0000
commit637303742581c6c061c3dcd0eb1ac78799b906e2 (patch)
tree065e42296a8d403d305079214e4bf4253efb278a /games-engines
parentx86 (diff)
downloadhistorical-637303742581c6c061c3dcd0eb1ac78799b906e2.tar.gz
historical-637303742581c6c061c3dcd0eb1ac78799b906e2.tar.bz2
historical-637303742581c6c061c3dcd0eb1ac78799b906e2.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog8
-rw-r--r--games-engines/scummvm/Manifest4
-rw-r--r--games-engines/scummvm/scummvm-1.2.0.ebuild84
3 files changed, 94 insertions, 2 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 9dac145fe0c6..1c70fe682230 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.94 2010/07/19 18:59:05 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.95 2010/10/19 21:38:48 mr_bones_ Exp $
+
+*scummvm-1.2.0 (19 Oct 2010)
+
+ 19 Oct 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-1.2.0.ebuild:
+ version bump
19 Jul 2010; Joseph Jezak <josejx@gentoo.org> scummvm-1.1.1.ebuild:
Marked ppc stable for bug #322633.
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index ae172e15dfd3..df72797793f7 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1,4 +1,6 @@
DIST scummvm-1.1.1.tar.bz2 8668735 RMD160 f581a5cae6821bae9b700ff1cb36a665ebefab61 SHA1 5f3dee411088987625f6351c721586a0ce6c3d42 SHA256 9cc865c5690bfc1df4970d35984455031467381180a71d84b08dcc9f51e39d4a
+DIST scummvm-1.2.0.tar.bz2 9514141 RMD160 c0c3f982c955fc9d39102fefa936b0d86b115157 SHA1 5443c3720179a9e75d46eb0282ec787637a76d36 SHA256 3ffc594d7ce3c14ad9bbbfaec70479f83a8bdbda81cf1eacf2988127f1d4dac0
EBUILD scummvm-1.1.1.ebuild 2345 RMD160 09e0ceb431f69802cd60cab739c93b5f526058d5 SHA1 8b0652cf1ff14c6412e85278b8dbab4e12c431f7 SHA256 c39fcfba3958f8a692ff969af411a08e452e7576d2b96eb0ec7be847265c4af0
-MISC ChangeLog 14000 RMD160 cdb782ad2bbe89c26ccb6d8f29ee7005b959da31 SHA1 643c47ebc49ed821708f951fad2104b72f4c4476 SHA256 b7472a6f8a4bafbe8d795fcbc2fb2ace9a025c1eee0492da24909f8a241d34c0
+EBUILD scummvm-1.2.0.ebuild 2348 RMD160 2a583fe437a1944f6ac7815954b702ecc30e0f65 SHA1 c0ead1aa73665b8fcb974f389e488ea789dece83 SHA256 8e4c4dc861b20eb1bbf05053f0e887a23000392e242a1607eb3645fc28e9a344
+MISC ChangeLog 14129 RMD160 cd97c3448f6b61f8748638f4ba49dd189b408647 SHA1 d537a133cf805c1619340b720ed9e0815980426c SHA256 7493025545f5533dd22bad22c37e8817ec39020ad58c7a753b8b21b24ef671d9
MISC metadata.xml 248 RMD160 ef65397fe4528a5ae0332b01a77e8f2a9e4c4e91 SHA1 a1c019c07494e52a3167dc8945533c2fd3ea1fc5 SHA256 d07430a4c6da117a018a33c479a43b812752dc8658311ae2559ef1d9f3654385
diff --git a/games-engines/scummvm/scummvm-1.2.0.ebuild b/games-engines/scummvm/scummvm-1.2.0.ebuild
new file mode 100644
index 000000000000..db8d95f3e28d
--- /dev/null
+++ b/games-engines/scummvm/scummvm-1.2.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-1.2.0.ebuild,v 1.1 2010/10/19 21:38:48 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P/_/}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND=">=media-libs/libsdl-1.2.2[audio,joystick,video]
+ >media-libs/libmpeg2-0.3.1
+ sys-libs/zlib
+ ogg? ( media-libs/libogg media-libs/libvorbis )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ alsa? ( media-libs/alsa-lib )
+ mp3? ( media-libs/libmad )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
+
+ # let the engine find its data files in the right place (bug #178116)
+ myconf="${myconf} --datadir=${GAMES_DATADIR}"
+
+ if use vorbis || use ogg ; then
+ myconf="${myconf} --enable-vorbis"
+ else
+ myconf="${myconf} --disable-vorbis"
+ fi
+
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ # mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
+ ./configure \
+ --enable-verbose-build \
+ --prefix=/usr \
+ --bindir="${GAMES_BINDIR}" \
+ --datadir="${GAMES_DATADIR}" \
+ --libdir="${GAMES_LIBDIR}" \
+ --enable-zlib \
+ $(use_enable debug) \
+ $(use_enable alsa) \
+ $(use_enable mp3 mad) \
+ $(use_enable flac) \
+ $(use_enable x86 nasm) \
+ ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ doicon icons/scummvm.svg
+ make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
+ prepgamesdirs
+}