summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-27 10:04:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-27 10:04:35 +0000
commit7392ac2e33c9ef95c138e606a346ee9d2cb56c0a (patch)
tree58ef9fba1f91ee4258bcad4534d61305c3970563 /games-fps
parentuse || in DEPEND and RDEPEND to say what we really mean (diff)
downloadhistorical-7392ac2e33c9ef95c138e606a346ee9d2cb56c0a.tar.gz
historical-7392ac2e33c9ef95c138e606a346ee9d2cb56c0a.tar.bz2
historical-7392ac2e33c9ef95c138e606a346ee9d2cb56c0a.zip
use || in RDEPEND to say what we really mean; depend on sed >= 4; error check sed
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake2-icculus/ChangeLog9
-rw-r--r--games-fps/quake2-icculus/Manifest5
-rw-r--r--games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild39
3 files changed, 35 insertions, 18 deletions
diff --git a/games-fps/quake2-icculus/ChangeLog b/games-fps/quake2-icculus/ChangeLog
index f3c78bdb11b2..ffa7b34d95ce 100644
--- a/games-fps/quake2-icculus/ChangeLog
+++ b/games-fps/quake2-icculus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/quake2-icculus
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.4 2004/01/08 05:56:20 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.5 2004/03/27 10:04:35 mr_bones_ Exp $
+
+ 27 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ quake2-icculus-0.15-r1.ebuild:
+ use || in RDEPEND to say what we really mean; depend on sed >= 4; error check
+ sed
*quake2-icculus-0.15-r1 (08 Jan 2004)
diff --git a/games-fps/quake2-icculus/Manifest b/games-fps/quake2-icculus/Manifest
index 8527e5706d1e..56f4997f3fd4 100644
--- a/games-fps/quake2-icculus/Manifest
+++ b/games-fps/quake2-icculus/Manifest
@@ -1,5 +1,6 @@
-MD5 97ac97a7e36b318679ebc8bb0d2346da ChangeLog 1016
-MD5 8163a790c9b37bb8fcfb83c0a1402949 quake2-icculus-0.15-r1.ebuild 4183
+MD5 b856def125fbe7675963724b7eb2c3bd ChangeLog 1199
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 2a381bcbb06765bbc0267281fb21c103 quake2-icculus-0.15-r1.ebuild 4341
MD5 2219e82edb75f4e2a9fa232afc365c5d files/0.15-Makefile-gcc3.patch 787
MD5 ad5de2e8c5c06b69b3b5a2dd926a758f files/0.15-Makefile-optflags.patch 260
MD5 fa58facee98afc741e1928b77be65065 files/README-postinstall 2695
diff --git a/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild b/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild
index 53a32bae8293..7fa2a9440cd9 100644
--- a/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild
+++ b/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild,v 1.2 2004/02/20 06:40:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.15-r1.ebuild,v 1.3 2004/03/27 10:04:35 mr_bones_ Exp $
-inherit games eutils gcc
+inherit eutils gcc games
-MY_P=quake2-r${PV}
-S=${WORKDIR}/${MY_P}
+MY_P="quake2-r${PV}"
+S="${WORKDIR}/${MY_P}"
DESCRIPTION="The icculus.org linux port of iD's quake2 engine"
HOMEPAGE="http://icculus.org/quake2/"
@@ -20,14 +20,17 @@ KEYWORDS="x86 ppc sparc alpha"
IUSE="svga X sdl aalib opengl noqmax rogue xatrix"
# default to X11 if svga/X/sdl/aalib are not in USE
-RDEPEND="svga? ( media-libs/svgalib )
- arts? ( kde-base/arts )
- X? ( virtual/x11 )
- sdl? ( media-libs/libsdl )
- aalib? ( media-libs/aalib )
+RDEPEND="virtual/glibc
opengl? ( virtual/opengl )
- || ( svga? ( "" ) X? ( "" ) sdl? ( "" ) aalib? ( "" ) virtual/x11 )"
+ || (
+ svga? ( media-libs/svgalib )
+ X? ( virtual/x11 )
+ sdl? ( media-libs/libsdl )
+ aalib? ( media-libs/aalib )
+ virtual/x11 )
+ arts? ( kde-base/arts )"
DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
app-arch/sharutils"
src_unpack() {
@@ -36,18 +39,27 @@ src_unpack() {
epatch ${FILESDIR}/${PV}-Makefile-noopts.patch
epatch ${FILESDIR}/${PV}-Makefile-optflags.patch
epatch ${FILESDIR}/${PV}-gentoo-path.patch
- sed -i "s:GENTOO_DATADIR:${GAMES_DATADIR}/quake2-data:" src/qcommon/files.c
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/quake2-data:" \
+ src/qcommon/files.c \
+ || die "sed src/qcommon/files.c failed"
ln -s `which echo` ${T}/more
for g in `use rogue` `use xatrix` ; do
mkdir -p ${S}/src/${g}
cd ${S}/src/${g}
unpack ${g}src320.shar.Z
- sed -i 's:^read ans:ans=yes :' ${g}src320.shar
+ sed -i \
+ -e 's:^read ans:ans=yes :' ${g}src320.shar \
+ || die "sed ${g}src320.shar failed"
env PATH="${T}:${PATH}" unshar ${g}src320.shar
rm ${g}src320.shar
done
- use rogue && sed -i 's:<nan\.h>:<bits/nan.h>:' ${S}/src/rogue/g_local.h
+ if use rogue ; then
+ sed -i \
+ -e 's:<nan\.h>:<bits/nan.h>:' ${S}/src/rogue/g_local.h \
+ || die "sed g_local.h failed"
+ fi
}
yesno() {
@@ -127,7 +139,6 @@ src_install() {
insinto ${q2maxdir}/baseq2
doins ${DISTDIR}/maxpak.pak
fi
-
prepgamesdirs
}