summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-20 08:08:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-20 08:08:46 +0000
commit8b953b4206de97d5f973b7d12c275a8f98c87362 (patch)
treeb0367d05751b13e5437cab62bd77046184bf2a15 /games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
parentUpdate use.local.desc for xfprint. (diff)
downloadhistorical-8b953b4206de97d5f973b7d12c275a8f98c87362.tar.gz
historical-8b953b4206de97d5f973b7d12c275a8f98c87362.tar.bz2
historical-8b953b4206de97d5f973b7d12c275a8f98c87362.zip
Fix lame logic (bug #141129)
Package-Manager: portage-2.1.1_pre3-r1
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
index b0ac3bdcc90f..77104b436279 100644
--- a/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.4 2006/07/19 18:25:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-1.99.1-r2.ebuild,v 1.5 2006/07/20 08:08:46 mr_bones_ Exp $
inherit eutils toolchain-funcs
@@ -30,8 +30,12 @@ src_unpack() {
-e "/^OFFENSIVE=/s:=.*:=`use offensive && echo 1 || echo 0`:" \
Makefile || die "sed Makefile failed"
- use elibc_FreeBSD && sed -i -e '/^REGEXLIBS=/s:=.*:= -lcompat:' \
- Makefile || die "sed REGEXLIBS failed"
+ if use elibc_FreeBSD ; then
+ sed -i \
+ -e '/^REGEXLIBS=/s:=.*:= -lcompat:' \
+ Makefile \
+ || die "sed REGEXLIBS failed"
+ fi
}
src_compile() {