summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 06:55:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 06:55:06 +0000
commit3dbd4b4a669f0574e18fb1e669b67bf83cd5ae37 (patch)
tree3cd9421cbf5ecec041480f22b1276d5d0d76a34c /games-puzzle/flobopuyo/flobopuyo-0.20.ebuild
parentSimplified ebuilds with epatch. (diff)
downloadhistorical-3dbd4b4a669f0574e18fb1e669b67bf83cd5ae37.tar.gz
historical-3dbd4b4a669f0574e18fb1e669b67bf83cd5ae37.tar.bz2
historical-3dbd4b4a669f0574e18fb1e669b67bf83cd5ae37.zip
initial commit - ebuild submitted by Rob Cakebread via bug #67028
Diffstat (limited to 'games-puzzle/flobopuyo/flobopuyo-0.20.ebuild')
-rw-r--r--games-puzzle/flobopuyo/flobopuyo-0.20.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild b/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild
new file mode 100644
index 000000000000..b7584866e9ea
--- /dev/null
+++ b/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/flobopuyo/flobopuyo-0.20.ebuild,v 1.1 2004/10/16 06:55:06 mr_bones_ Exp $
+
+inherit toolchain-funcs games
+
+DESCRIPTION="Clone of the famous PuyoPuyo game"
+HOMEPAGE="http://www.ios-software.com/?page=projet&quoi=29"
+SRC_URI="http://www.ios-software.com/flobopuyo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ virtual/opengl"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find . -type f -name ".*" -exec rm -f \{\} \;
+ sed -i \
+ -e "s:^DATADIR=.*:DATADIR=\"${GAMES_DATADIR}/${PN}\":" \
+ -e "/^INSTALL_BINDIR/s:/\$(PREFIX)/games:${GAMES_BINDIR}:" \
+ -e "/^CC=/s/g++/$(tc-getCXX)/" \
+ -e "/^CXX=/s/g++/$(tc-getCXX)/" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog TODO
+ prepgamesdirs
+}