summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-24 19:10:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-24 19:10:33 +0000
commit08fee09059de748cafbc04c067e93ec7a8aa89ad (patch)
treed0d18ae7e97b054d76c9e4e67883425ae73898b3 /games-puzzle/quadros
parentrevision bump, include fixes for supporting errors from transcode (diff)
downloadhistorical-08fee09059de748cafbc04c067e93ec7a8aa89ad.tar.gz
historical-08fee09059de748cafbc04c067e93ec7a8aa89ad.tar.bz2
historical-08fee09059de748cafbc04c067e93ec7a8aa89ad.zip
initial commit - ebuild submitted by MaratIK via bug #63212
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'games-puzzle/quadros')
-rw-r--r--games-puzzle/quadros/ChangeLog10
-rw-r--r--games-puzzle/quadros/Manifest4
-rw-r--r--games-puzzle/quadros/files/digest-quadros-0.11
-rw-r--r--games-puzzle/quadros/metadata.xml5
-rw-r--r--games-puzzle/quadros/quadros-0.1.ebuild39
5 files changed, 59 insertions, 0 deletions
diff --git a/games-puzzle/quadros/ChangeLog b/games-puzzle/quadros/ChangeLog
new file mode 100644
index 000000000000..e6d6971f6fac
--- /dev/null
+++ b/games-puzzle/quadros/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-puzzle/quadros
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/quadros/ChangeLog,v 1.1 2005/01/24 19:10:33 mr_bones_ Exp $
+
+*quadros-0.1 (24 Jan 2005)
+
+ 24 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +quadros-0.1.ebuild:
+ initial commit - ebuild submitted by MaratIK via bug #63212
+
diff --git a/games-puzzle/quadros/Manifest b/games-puzzle/quadros/Manifest
new file mode 100644
index 000000000000..96b8456809f4
--- /dev/null
+++ b/games-puzzle/quadros/Manifest
@@ -0,0 +1,4 @@
+MD5 2fe12e19c0cf98f505d415be2c231b6c quadros-0.1.ebuild 1110
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 039534fc1d22f133dc411dce789f9ccd ChangeLog 400
+MD5 d5a99be8987096fcc2141f77237f4113 files/digest-quadros-0.1 63
diff --git a/games-puzzle/quadros/files/digest-quadros-0.1 b/games-puzzle/quadros/files/digest-quadros-0.1
new file mode 100644
index 000000000000..d93c8691b90e
--- /dev/null
+++ b/games-puzzle/quadros/files/digest-quadros-0.1
@@ -0,0 +1 @@
+MD5 57aef740147839bf1266a53d35042d8c quadros-0.1.tar.gz 730745
diff --git a/games-puzzle/quadros/metadata.xml b/games-puzzle/quadros/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/quadros/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/quadros/quadros-0.1.ebuild b/games-puzzle/quadros/quadros-0.1.ebuild
new file mode 100644
index 000000000000..46753d1ea2e1
--- /dev/null
+++ b/games-puzzle/quadros/quadros-0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/quadros/quadros-0.1.ebuild,v 1.1 2005/01/24 19:10:33 mr_bones_ Exp $
+
+inherit kde games
+need-qt 3
+
+DESCRIPTION="An implementation of the Tetris game with team multiplayer ability"
+HOMEPAGE="http://quadros.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quadros/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+src_unpack() {
+ kde_src_unpack
+}
+
+src_compile() {
+ kde_src_compile nothing
+ qmake -project -o quadros.pro
+ # Need generating .pro file from scratch
+ # because shipped src/quadros.pro is corrupted
+ # and shipped configure scripts requires pre-installed kde-libs
+ # and other stuff like dcopidl,...
+ # which are not required by game
+ echo "QMAKE_CXXFLAGS += ${CXXFLAGS}" >> quadros.pro
+ echo "CONFIG += qt thread warn_on release" >> quadros.pro
+ qmake -o Makefile quadros.pro
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin quadros || die "dogamesbin failed"
+ dodoc AUTHORS ChangeLog TODO NEWS README
+ prepgamesdirs
+}