summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-14 16:51:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-14 16:51:56 +0000
commitd6e1b2dc627d187694621a345b152d5d3157b381 (patch)
tree069a84e30d5e774e64dfeef6f26dfb7a887bb79e /games-roguelike/tome/tome-2.2.5-r1.ebuild
parentupdated dates in ebuilds, added to the start cmd line to pass extra options ... (diff)
downloadhistorical-d6e1b2dc627d187694621a345b152d5d3157b381.tar.gz
historical-d6e1b2dc627d187694621a345b152d5d3157b381.tar.bz2
historical-d6e1b2dc627d187694621a345b152d5d3157b381.zip
move scores file to /var/games #37594
Diffstat (limited to 'games-roguelike/tome/tome-2.2.5-r1.ebuild')
-rw-r--r--games-roguelike/tome/tome-2.2.5-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/games-roguelike/tome/tome-2.2.5-r1.ebuild b/games-roguelike/tome/tome-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..533d22d253f7
--- /dev/null
+++ b/games-roguelike/tome/tome-2.2.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.5-r1.ebuild,v 1.1 2004/01/14 16:51:56 vapier Exp $
+
+inherit games eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tgz"
+
+LICENSE="Moria"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5
+ virtual/x11"
+
+S=${WORKDIR}/tome-${MY_PV}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ mv makefile.std makefile
+ epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ sed -i "s:GENTOO_DIR:${GAMES_STATEDIR}:" files.c init2.c
+}
+
+src_compile() {
+ cd src
+ emake -j1 \
+ COPTS="${CFLAGS}" \
+ BINDIR=${GAMES_BINDIR} \
+ LIBDIR=${GAMES_DATADIR}/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ cd src
+ emake -j1 \
+ OWNER=${GAMES_USER} \
+ BINDIR=${D}/${GAMES_BINDIR} \
+ LIBDIR=${D}/${GAMES_DATADIR}/${PN} install \
+ || die "make install failed"
+ cd ${S}
+ dodoc *.txt
+
+ dodir ${GAMES_STATEDIR}
+ touch ${D}/${GAMES_STATEDIR}/${PN}-scores.raw
+ prepgamesdirs
+ fperms g+w ${GAMES_STATEDIR}/${PN}-scores.raw
+ fperms g+w ${GAMES_DATADIR}/${PN}/data
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "ToME ${PV} is not save-game compatible with previous versions."
+ echo
+ einfo "If you have older save files and you wish to continue those games,"
+ einfo "you'll need to remerge the version of ToME with which you started"
+ einfo "those save-games."
+}