summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-12 22:47:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-12 22:47:26 +0000
commit1cff7eefc37de87730adfa26c147964c240b81db (patch)
tree596332eb55cb1fc0e1f5193af913006552e054bf /games-rpg/coe2/coe2-2007.ebuild
parentStable on alpha, bug #253668 (diff)
downloadhistorical-1cff7eefc37de87730adfa26c147964c240b81db.tar.gz
historical-1cff7eefc37de87730adfa26c147964c240b81db.tar.bz2
historical-1cff7eefc37de87730adfa26c147964c240b81db.zip
EAPI=2; fix improper die usage (bug #258770)
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28.1 i686
Diffstat (limited to 'games-rpg/coe2/coe2-2007.ebuild')
-rw-r--r--games-rpg/coe2/coe2-2007.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-rpg/coe2/coe2-2007.ebuild b/games-rpg/coe2/coe2-2007.ebuild
index 7ca1bfc0aa5e..720a93d3ebf8 100644
--- a/games-rpg/coe2/coe2-2007.ebuild
+++ b/games-rpg/coe2/coe2-2007.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/coe2-2007.ebuild,v 1.1 2007/08/29 21:38:39 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/coe2/coe2-2007.ebuild,v 1.2 2009/02/12 22:47:26 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Precursor to the Dominions series"
@@ -19,13 +20,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/coe
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
rm *.{dll,exe}
rm -r old
- use amd64 && mv -f coe_linux64bit coe_linux || die "mv amd64 image failed"
+ if use amd64 ; then
+ mv -f coe_linux64bit coe_linux || die "mv amd64 image failed"
+ fi
}
src_install() {