summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-04 02:23:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-04 02:23:03 +0000
commitc7e87fb6125b7e0e035f0686118c1f1cb6ebd391 (patch)
tree7be6343d409c3f93a95c955c88c2c8ff94b5e59f /games-sports
parentChanging mad dep to madplay. (diff)
downloadhistorical-c7e87fb6125b7e0e035f0686118c1f1cb6ebd391.tar.gz
historical-c7e87fb6125b7e0e035f0686118c1f1cb6ebd391.tar.bz2
historical-c7e87fb6125b7e0e035f0686118c1f1cb6ebd391.zip
IUSE
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/foosball/foosball-0.92.ebuild5
-rw-r--r--games-sports/race/race-0.5.ebuild3
-rw-r--r--games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild11
-rw-r--r--games-sports/soccar/soccar-0.5.2.ebuild12
4 files changed, 19 insertions, 12 deletions
diff --git a/games-sports/foosball/foosball-0.92.ebuild b/games-sports/foosball/foosball-0.92.ebuild
index 842139dfdf6a..8204e8f78a28 100644
--- a/games-sports/foosball/foosball-0.92.ebuild
+++ b/games-sports/foosball/foosball-0.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/foosball-0.92.ebuild,v 1.3 2004/03/20 12:59:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foosball/foosball-0.92.ebuild,v 1.4 2004/05/04 02:23:03 mr_bones_ Exp $
inherit games
@@ -11,11 +11,12 @@ SRC_URI="http://www.autismuk.freeserve.co.uk/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
+IUSE=""
DEPEND="media-libs/libsdl"
src_install() {
- emake install DESTDIR=${D} || die
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}
diff --git a/games-sports/race/race-0.5.ebuild b/games-sports/race/race-0.5.ebuild
index 87100e85b9a8..d81715daadc3 100644
--- a/games-sports/race/race-0.5.ebuild
+++ b/games-sports/race/race-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.4 2004/02/29 21:20:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.5 2004/05/04 02:20:11 mr_bones_ Exp $
inherit games gcc eutils
@@ -11,6 +11,7 @@ SRC_URI="ftp://users.freebsd.org.uk/pub/foobar2k/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
RDEPEND="virtual/opengl
virtual/glu
diff --git a/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild b/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
index 8e002ef6933b..438b94570bbe 100644
--- a/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
+++ b/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild,v 1.3 2004/03/20 12:59:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/racer-bin/racer-bin-0.5.0-r1.ebuild,v 1.4 2004/05/04 02:19:04 mr_bones_ Exp $
inherit games
@@ -12,13 +12,14 @@ SRC_URI="http://download.tdconline.dk/pub/boomtown/racesimcentral/rr_data${PV}.t
LICENSE="Racer"
SLOT="0"
KEYWORDS="-* x86"
+IUSE=""
RDEPEND="virtual/opengl
media-libs/libsdl
sys-libs/lib-compat
>=media-libs/fmod-3.61"
-S=${WORKDIR}/racer${PV}
+S="${WORKDIR}/racer${PV}"
src_compile() {
einfo "Binary package. Nothing to compile"
@@ -31,10 +32,10 @@ src_install( ) {
dodoc *.txt || die "dodoc failed"
rm -f *.txt
- cp -R ${S}/* ${D}/${dir}/ || die "cp failed"
+ cp -R ${S}/* "${D}/${dir}/" || die "cp failed"
- sed -e "s:GENTOO_DIR:${dir}:" ${FILESDIR}/racer-skel > racer-skel || \
- die "sed failed"
+ sed -e "s:GENTOO_DIR:${dir}:" "${FILESDIR}/racer-skel" > racer-skel \
+ || die "sed failed"
for f in carlab gplex modeler pacejka racer tracked
do
diff --git a/games-sports/soccar/soccar-0.5.2.ebuild b/games-sports/soccar/soccar-0.5.2.ebuild
index d33006b18f4b..def6bd4e4175 100644
--- a/games-sports/soccar/soccar-0.5.2.ebuild
+++ b/games-sports/soccar/soccar-0.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/soccar/soccar-0.5.2.ebuild,v 1.3 2004/03/20 12:59:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/soccar/soccar-0.5.2.ebuild,v 1.4 2004/05/04 02:17:26 mr_bones_ Exp $
inherit games eutils
@@ -12,6 +12,7 @@ SRC_URI="mirror://sourceforge/soccar/${P}-src.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
+IUSE=""
DEPEND="dev-util/jam
dev-games/ogre
@@ -22,9 +23,12 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-cfg-reloc.patch
- sed -i "s:GENTOO_CFGDIR:${GAMES_SYSCONFDIR}/${PN}:" src/{app,config}.cpp
- sed -i "s:-g -O2:${CXXFLAGS} `pkg-config OGRE --cflags`:" src/Jamfile
- sed -i 's:/local/:/:' plugins.cfg
+ sed -i \
+ -e "s:GENTOO_CFGDIR:${GAMES_SYSCONFDIR}/${PN}:" src/{app,config}.cpp
+ sed -i \
+ -e "s:-g -O2:${CXXFLAGS} `pkg-config OGRE --cflags`:" src/Jamfile
+ sed -i \
+ -e 's:/local/:/:' plugins.cfg
}
src_compile() {