summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-06 22:53:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-06 22:53:59 +0000
commit9df161753617578fbd2164af5e02709139886da7 (patch)
tree52ce54e24744263aaf74e2b81d642b65964a6739 /games-strategy
parentFix log files permissions in logrotate config file (#113803). (diff)
downloadhistorical-9df161753617578fbd2164af5e02709139886da7.tar.gz
historical-9df161753617578fbd2164af5e02709139886da7.tar.bz2
historical-9df161753617578fbd2164af5e02709139886da7.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog7
-rw-r--r--games-strategy/glob2/Manifest4
-rw-r--r--games-strategy/glob2/files/digest-glob2-0.8.161
-rw-r--r--games-strategy/glob2/glob2-0.8.16.ebuild53
4 files changed, 63 insertions, 2 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index 04878f59d973..d819355ed81c 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.24 2005/10/12 22:55:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.25 2005/12/06 22:53:58 mr_bones_ Exp $
+
+*glob2-0.8.16 (06 Dec 2005)
+
+ 06 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org> +glob2-0.8.16.ebuild:
+ version bump
12 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org> glob2-0.8.15.ebuild:
add desktop entry support (bug #109043)
diff --git a/games-strategy/glob2/Manifest b/games-strategy/glob2/Manifest
index 3f211449bb22..3ef795ec2935 100644
--- a/games-strategy/glob2/Manifest
+++ b/games-strategy/glob2/Manifest
@@ -1,4 +1,6 @@
MD5 be3faa436a456146cab34d1a7ba5e534 metadata.xml 546
-MD5 25d510561aad18df0279755d4000097b ChangeLog 2895
+MD5 3a295465b97703634eee351cea1347f1 ChangeLog 3017
+MD5 cbc9d911c20649e5f4200a52bd1dfb98 glob2-0.8.16.ebuild 1285
MD5 bad48144211e306ea91a7571e7982fc9 glob2-0.8.15.ebuild 1073
+MD5 037d75d9848a508583262c6ab6653c9e files/digest-glob2-0.8.16 65
MD5 222d938fd35ab1fb95eaf828c73203d5 files/digest-glob2-0.8.15 65
diff --git a/games-strategy/glob2/files/digest-glob2-0.8.16 b/games-strategy/glob2/files/digest-glob2-0.8.16
new file mode 100644
index 000000000000..021d5e1fca85
--- /dev/null
+++ b/games-strategy/glob2/files/digest-glob2-0.8.16
@@ -0,0 +1 @@
+MD5 c612c8278dde0f602fd8388bd961503c glob2-0.8.16.tar.gz 8868021
diff --git a/games-strategy/glob2/glob2-0.8.16.ebuild b/games-strategy/glob2/glob2-0.8.16.ebuild
new file mode 100644
index 000000000000..2c3d060ab78b
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.8.16.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.8.16.ebuild,v 1.1 2005/12/06 22:53:58 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://www.ysagoon.com/glob2/"
+SRC_URI="http://epfl.ysagoon.com/~glob2/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.0
+ media-libs/libpng
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/libvorbis
+ >=media-libs/speex-1.1
+ =media-libs/freetype-2*
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^glob2linkdir/s:\$(datadir):/usr/share:" \
+ data/Makefile.in \
+ || die "sed failed"
+ sed -i \
+ -e "/^glob2icondir/s:\$(datadir):/usr/share:" \
+ data/icons/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ #./configure assumes that vorbis will be installed under PREFIX bug #46352
+ egamesconf \
+ --with-vorbis=/usr \
+ --with-speex=/usr \
+ --with-speex-includes=/usr/include/speex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO
+ prepgamesdirs
+}