summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:24:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-29 08:24:46 +0000
commit87d3dbe71ada20ccf8401326d0a85460c3e873ca (patch)
tree15b1c0c836488d6b6283a2fbd3111e2cb264d561 /games-util/joystick/joystick-20060731.ebuild
parentEAPI=2; add use-based dep for qt (bug #247344) (diff)
downloadhistorical-87d3dbe71ada20ccf8401326d0a85460c3e873ca.tar.gz
historical-87d3dbe71ada20ccf8401326d0a85460c3e873ca.tar.bz2
historical-87d3dbe71ada20ccf8401326d0a85460c3e873ca.zip
EAPI=2; respect CC
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.28.1 i686
Diffstat (limited to 'games-util/joystick/joystick-20060731.ebuild')
-rw-r--r--games-util/joystick/joystick-20060731.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/games-util/joystick/joystick-20060731.ebuild b/games-util/joystick/joystick-20060731.ebuild
index f67521de7d00..140b4d30bb17 100644
--- a/games-util/joystick/joystick-20060731.ebuild
+++ b/games-util/joystick/joystick-20060731.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.3 2007/04/19 22:32:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20060731.ebuild,v 1.4 2009/01/29 08:24:46 mr_bones_ Exp $
-inherit eutils
+EAPI=2
+inherit eutils toolchain-funcs
DESCRIPTION="joystick testing utilities"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
@@ -17,16 +18,19 @@ DEPEND="sdl? ( media-libs/libsdl )"
S=${WORKDIR}/utils
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/joystick-MCS-defines.patch \
"${FILESDIR}"/joystick-jstest-segv.patch
+ sed -i \
+ -e '/^CC/d' \
+ Makefile \
+ || die 'sed failed'
}
src_compile() {
local SDL
+ tc-export CC
use sdl && SDL=1 || SDL=0
emake SDL=${SDL} || die "emake failed"
emake inputattach || die "inputattach failed"