summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-14 16:48:12 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-14 16:48:12 +0000
commit368e929e895e20adff7ec301e083696444bca54e (patch)
tree006b80149451b70e7d4314602d89e6e73b374460 /gnome-base/ORBit
parentchango (diff)
downloadhistorical-368e929e895e20adff7ec301e083696444bca54e.tar.gz
historical-368e929e895e20adff7ec301e083696444bca54e.tar.bz2
historical-368e929e895e20adff7ec301e083696444bca54e.zip
Whoops! Adding the important files.
Diffstat (limited to 'gnome-base/ORBit')
-rw-r--r--gnome-base/ORBit/ORBit-0.5.13-r1.ebuild58
-rw-r--r--gnome-base/ORBit/files/alloca.diff11
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-base/ORBit/ORBit-0.5.13-r1.ebuild b/gnome-base/ORBit/ORBit-0.5.13-r1.ebuild
new file mode 100644
index 000000000000..f78452c736df
--- /dev/null
+++ b/gnome-base/ORBit/ORBit-0.5.13-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/ORBit/ORBit-0.5.13-r1.ebuild,v 1.1 2002/02/14 16:48:12 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A high-performance, lightweight CORBA ORB aiming for CORBA 2.2 compliance"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.labs.redhat.com/orbit/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-apps/tcp-wrappers-7.6
+ >=dev-libs/glib-1.2.8"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-1.2.8"
+
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ patch -p0 < ${FILESDIR}/alloca.diff
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+ dodoc docs/*.txt docs/IDEA1
+
+ docinto idl
+ cd libIDL
+ dodoc AUTHORS BUGS COPYING NEWS README*
+
+ docinto popt
+ cd ../popt
+ dodoc CHANGES COPYING README
+
+ cd ${D}/usr/lib
+ patch -p0 < ${FILESDIR}/libIDLConf.sh-gentoo.diff
+}
+
+
+
diff --git a/gnome-base/ORBit/files/alloca.diff b/gnome-base/ORBit/files/alloca.diff
new file mode 100644
index 000000000000..c77c6fa97c64
--- /dev/null
+++ b/gnome-base/ORBit/files/alloca.diff
@@ -0,0 +1,11 @@
+--- src/ORBitutil/os-feature-alloca.h 2000-01-18 11:36:13.000000000 -0500
++++ src/ORBitutil/os-feature-alloca.h 2002-02-10 02:39:26.000000000 -0500
+@@ -9,7 +9,7 @@
+
+ # if defined(__GNUC__)
+
+-# if defined(__STRICT_ANSI__)
++# if defined(__STRICT_ANSI__) && !defined(alloca)
+ # define alloca __builtin_alloca
+ # endif
+