summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-13 21:33:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-09-13 21:33:36 +0000
commit215b0fcc9f572072aa5ab1a9d7cfee6049e01977 (patch)
tree5cd88add344b4c6d9abbadff223795c319b5ce56 /gnome-base/gnome-keyring/files
parentVersion bump. (diff)
downloadhistorical-215b0fcc9f572072aa5ab1a9d7cfee6049e01977.tar.gz
historical-215b0fcc9f572072aa5ab1a9d7cfee6049e01977.tar.bz2
historical-215b0fcc9f572072aa5ab1a9d7cfee6049e01977.zip
Fix the test.make fragment to properly build in parallel, closes bug #272450.
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'gnome-base/gnome-keyring/files')
-rw-r--r--gnome-base/gnome-keyring/files/gnome-keyring-2.26.3-parallel-tests.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/gnome-keyring/files/gnome-keyring-2.26.3-parallel-tests.patch b/gnome-base/gnome-keyring/files/gnome-keyring-2.26.3-parallel-tests.patch
new file mode 100644
index 000000000000..abd57bfa4f4e
--- /dev/null
+++ b/gnome-base/gnome-keyring/files/gnome-keyring-2.26.3-parallel-tests.patch
@@ -0,0 +1,43 @@
+Index: gnome-keyring-2.26.3/tests/test.make
+===================================================================
+--- gnome-keyring-2.26.3.orig/tests/test.make
++++ gnome-keyring-2.26.3/tests/test.make
+@@ -22,9 +22,11 @@ noinst_PROGRAMS= \
+ run-auto-test \
+ run-prompt-test
+
+-run-auto-test.c: $(UNIT_AUTO) Makefile.am
++run-auto-test.h: $(UNIT_AUTO) Makefile.am
+ sh $(top_srcdir)/tests/prep-tests.sh -b run-auto-test $(UNIT_AUTO)
+
++run-auto-test.c: run-auto-test.h
++
+ run_auto_test_SOURCES = \
+ run-auto-test.c \
+ run-auto-test.h \
+@@ -37,9 +39,11 @@ run_auto_test_LDADD = \
+ run_auto_test_CFLAGS = \
+ $(UNIT_FLAGS)
+
+-run-prompt-test.c: $(UNIT_PROMPT) Makefile.am
++run-prompt-test.h: $(UNIT_PROMPT) Makefile.am
+ sh $(top_srcdir)/tests/prep-tests.sh -b run-prompt-test $(UNIT_PROMPT)
+
++run-prompt-test.c: run-prompt-test.h
++
+ run_prompt_test_SOURCES = \
+ run-prompt-test.c \
+ run-prompt-test.h \
+@@ -52,6 +56,12 @@ run_prompt_test_LDADD = \
+ run_prompt_test_CFLAGS = \
+ $(UNIT_FLAGS)
+
++BUILT_SOURCES = \
++ run-auto-test.c \
++ run-auto-test.h \
++ run-prompt-test.c \
++ run-prompt-test.h
++
+ # ------------------------------------------------------------------------------
+ # Run the tests
+