summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-31 01:40:23 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-31 01:40:23 +0000
commit6b30e68a4d3ad4932ce759db4cfa1b83b7fa4b95 (patch)
treed3a9713db81e89a12c3514acd2792b7e2b92d828 /gnome-base/gnome-vfs
parentpart of gnome2.2 rc2 mask (diff)
downloadhistorical-6b30e68a4d3ad4932ce759db4cfa1b83b7fa4b95.tar.gz
historical-6b30e68a4d3ad4932ce759db4cfa1b83b7fa4b95.tar.bz2
historical-6b30e68a4d3ad4932ce759db4cfa1b83b7fa4b95.zip
gnome2.2 rc2 commit
Diffstat (limited to 'gnome-base/gnome-vfs')
-rw-r--r--gnome-base/gnome-vfs/ChangeLog8
-rw-r--r--gnome-base/gnome-vfs/files/digest-gnome-vfs-2.2.01
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2-oggdetect.diff21
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild6
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.2.0.ebuild57
5 files changed, 90 insertions, 3 deletions
diff --git a/gnome-base/gnome-vfs/ChangeLog b/gnome-base/gnome-vfs/ChangeLog
index f8321bf503ce..b5125fb91dbd 100644
--- a/gnome-base/gnome-vfs/ChangeLog
+++ b/gnome-base/gnome-vfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-vfs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.35 2003/01/08 22:28:35 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.36 2003/01/31 01:40:23 foser Exp $
+
+*gnome-vfs-2.2.0 (30 Jan 2003)
+
+ 30 Jan 2003; foser <foser@gentoo.org> gnome-vfs-2.2.0.ebuild :
+ GNOME 2.2 rc2 commit
+ added ogg detection patch
09 Jan 2003; Martin Schlemmer <azarah@gentoo.org> gnome-vfs-1.0.5-r3.ebuild :
Mark stable, as evo-1.2.1 are unmasked ...
diff --git a/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.2.0 b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.2.0
new file mode 100644
index 000000000000..c109c7eb7f70
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.2.0
@@ -0,0 +1 @@
+MD5 da9caa0a7d2793b99b13fd3ba7ba1391 gnome-vfs-2.2.0.tar.bz2 968448
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2-oggdetect.diff b/gnome-base/gnome-vfs/files/gnome-vfs-2-oggdetect.diff
new file mode 100644
index 000000000000..3f852154abf5
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2-oggdetect.diff
@@ -0,0 +1,21 @@
+Index: libgnomevfs/gnome-vfs-mime-magic.c
+===================================================================
+RCS file: /cvs/gnome/gnome-vfs/libgnomevfs/gnome-vfs-mime-magic.c,v
+retrieving revision 1.43
+diff -u -r1.43 gnome-vfs-mime-magic.c
+--- libgnomevfs/gnome-vfs-mime-magic.c 19 Dec 2002 17:57:19 -0000 1.43
++++ libgnomevfs/gnome-vfs-mime-magic.c 20 Jan 2003 12:57:20 -0000
+@@ -855,6 +855,13 @@
+ && (sniff_buffer->buffer[7] < 0x80u)
+ && (sniff_buffer->buffer[8] < 0x80u)
+ && (sniff_buffer->buffer[9] < 0x80u)) {
++ /* checks for existance of vorbis identification header */
++ for (offset=10; offset < GNOME_VFS_MP3_SNIFF_LENGTH-7; offset++) {
++ if (strncmp ((char *) &sniff_buffer->buffer[offset],
++ "\x01vorbis", 7) == 0) {
++ return FALSE;
++ }
++ }
+ return TRUE;
+ }
+
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild
index 2cede501562e..3f33063fd5f8 100644
--- a/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild,v 1.6 2002/12/24 20:41:36 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.0.4.1.ebuild,v 1.7 2003/01/31 01:40:23 foser Exp $
IUSE="doc"
-inherit gnome2
+inherit gnome2 libtool
S=${WORKDIR}/${P}
DESCRIPTION="Gnome Virtual Filesystem"
@@ -31,6 +31,8 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS COPYING* ChangeLog HACKING INSTALL NEWS README TODO"
src_compile() {
+ elibtoolize
+
gnome2_src_compile DESTDIR=${D}
}
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.2.0.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.2.0.ebuild
new file mode 100644
index 000000000000..edb14b29e8f7
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.2.0.ebuild,v 1.1 2003/01/31 01:40:23 foser Exp $
+
+IUSE="doc ssl"
+
+inherit gnome2 eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="2"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-base/gconf-1.2.1
+ >=gnome-base/ORBit2-2.4
+ >=gnome-base/libbonobo-2
+ >=gnome-base/bonobo-activation-1
+ >=dev-libs/libxml2-2.2.8
+ >=sys-devel/gettext-0.10.40
+ app-admin/fam-oss
+ ssl? ( >=dev-libs/openssl-0.9.5 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.22
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+DOCS="AUTHORS COPYING* ChangeLog HACKING INSTALL NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+
+ # fixes oggs with id3 tags detection
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2-oggdetect.diff
+}
+
+src_compile() {
+ gnome2_src_compile DESTDIR=${D}
+}
+
+src_install() {
+ gnome2_src_install
+ # FIXME: there are bettere ways
+ echo "trash: libvfolder-desktop.so">>${D}/etc/gnome-vfs-2.0/modules/default-modules.conf
+}
+
+pkg_preinst () {
+ ## this check is there because gnome-vfs still adheres the file, though it doesn't need it. backwards compliance isnt always good
+ REMOVE="${ROOT}/etc/gnome-vfs-2.0/vfolders/applications.vfolder-info"
+ if [ -f ${REMOVE} ] ; then
+ rm -f ${REMOVE}
+ fi
+}