summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-20 09:33:28 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-20 09:33:28 +0000
commit33f5dc99454da058413ffb41dd1ec87f98f4533e (patch)
tree8f5025a3ad54ed2546e95411ab8da21709994edf /gnome-base
parentdepend on python >= 2.2, also fixed the dependencies since the RDEPEND was al... (diff)
downloadhistorical-33f5dc99454da058413ffb41dd1ec87f98f4533e.tar.gz
historical-33f5dc99454da058413ffb41dd1ec87f98f4533e.tar.bz2
historical-33f5dc99454da058413ffb41dd1ec87f98f4533e.zip
fix sandbox violations
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-print/files/digest-gnome-print-0.34-r11
-rw-r--r--gnome-base/gnome-print/gnome-print-0.34-r1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-base/gnome-print/files/digest-gnome-print-0.34-r1 b/gnome-base/gnome-print/files/digest-gnome-print-0.34-r1
new file mode 100644
index 000000000000..8fbeafaf3fe9
--- /dev/null
+++ b/gnome-base/gnome-print/files/digest-gnome-print-0.34-r1
@@ -0,0 +1 @@
+MD5 af477455dca1c68539343a26a04e6c2b gnome-print-0.34.tar.gz 1003520
diff --git a/gnome-base/gnome-print/gnome-print-0.34-r1.ebuild b/gnome-base/gnome-print/gnome-print-0.34-r1.ebuild
new file mode 100644
index 000000000000..029cb180dd0e
--- /dev/null
+++ b/gnome-base/gnome-print/gnome-print-0.34-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.34-r1.ebuild,v 1.1 2002/01/20 09:33:28 azarah Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="gnome-print"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/freetype-2.0.1"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ sys-devel/perl
+ tex? ( app-text/tetex )
+ >=app-text/ghostscript-6.50-r2"
+
+src_unpack() {
+ unpack ${A}
+
+ #fix Makefile not to run gnome-font-install
+ cp ${S}/installer/Makefile.in ${S}/installer/Makefile.in.orig
+ sed -e 's:$(PERL) $(top_srcdir)/run-gnome-font-install:echo $(top_srcdir)/run-gnome-font-install:' \
+ ${S}/installer/Makefile.in.orig > ${S}/installer/Makefile.in
+}
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ sysconfdir=${D}/etc \
+ install || die
+
+ insinto /usr/share/fonts
+ doins ${S}/run-gnome-font-install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ldconfig >/dev/null 2>/dev/null
+ echo ">>> Installing fonts"
+ perl /usr/share/fonts/run-gnome-font-install \
+ /usr/bin/gnome-font-install \
+ /usr/share/fonts /usr/share/fonts /etc >/dev/null 2>/dev/null
+}