summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-05-04 14:28:03 +0000
committerMarinus Schraal <foser@gentoo.org>2004-05-04 14:28:03 +0000
commitc3a3c6c728799d1fed43b7b868834a946ea58ea2 (patch)
treedd4aabbde2f4ebee4c5948dc28fa9cb8e3f9a4e9 /gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild
parentClean up this ebuild, heading toward convergence with mozilla and mozilla-fir... (diff)
downloadhistorical-c3a3c6c728799d1fed43b7b868834a946ea58ea2.tar.gz
historical-c3a3c6c728799d1fed43b7b868834a946ea58ea2.tar.bz2
historical-c3a3c6c728799d1fed43b7b868834a946ea58ea2.zip
new release
Diffstat (limited to 'gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild')
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild
new file mode 100644
index 000000000000..5609b2a7ea6f
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-2.6.1.ebuild,v 1.1 2004/05/04 14:28:03 foser Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="a Gtk+ based HTML rendering library"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="LGPL-2.1 GPL-2"
+
+IUSE="accessibility"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+
+# FIXME : seems only testapps need gnomevfs
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/libxml2-2.4.16
+ >=gnome-base/gnome-vfs-2
+ accessibility? ( >=gnome-base/gail-1.3 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+G2CONF="${G2CONF} $(use_enable accessibility)"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO docs/IDEAS"
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ if use alpha; then
+ epatch ${FILESDIR}/${PN}-2.2.0-alpha.patch || die
+ fi
+
+}