summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:58:29 +0000
committerArmando Di Cianno <fafhrd@gentoo.org>2004-11-12 03:58:29 +0000
commita9bc49aa10fecdc6e69ff3891b5fc01b82835f0d (patch)
tree7601a6a1b4e03604e833e594167512da2444cb93 /gnustep-libs/renaissance/renaissance-0.8.0.ebuild
parentMass Update: gnustep.eclass revamped to allow configurable root install; gnus... (diff)
downloadhistorical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.tar.gz
historical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.tar.bz2
historical-a9bc49aa10fecdc6e69ff3891b5fc01b82835f0d.zip
Mass Update: gnustep.eclass revamped to allow configurable root install; gnustep-base/libs/apps updated to utilize new gnustep.eclass (only versions bumped where files would change); some KEYWORDS were accidentally dropped between version bumps of packages -- this has been resolved; windowmaker correctly supports gnustep now; gnustep-funcs.eclass added -- used where info on an installed gnustep-env is needed rather than making a full GNUstep application
Diffstat (limited to 'gnustep-libs/renaissance/renaissance-0.8.0.ebuild')
-rw-r--r--gnustep-libs/renaissance/renaissance-0.8.0.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnustep-libs/renaissance/renaissance-0.8.0.ebuild b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
index c3cb24a49870..3017a18d2c96 100644
--- a/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
+++ b/gnustep-libs/renaissance/renaissance-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.0.ebuild,v 1.2 2004/10/21 19:09:54 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/renaissance/renaissance-0.8.0.ebuild,v 1.3 2004/11/12 03:58:29 fafhrd Exp $
inherit gnustep
@@ -18,6 +18,8 @@ IUSE="${IUSE} doc"
DEPEND="${GS_DEPEND}"
RDEPEND="${GS_RDEPEND}"
+egnustep_install_domain "System"
+
src_install() {
cd ${S}
egnustep_env
@@ -28,9 +30,9 @@ src_install() {
egnustep_make
egnustep_install
mkdir -p ${TMP}/tmpdocs
- mv ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/* ${TMP}/tmpdocs
- mkdir -p ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
- mv ${TMP}/tmpdocs/* ${D}${GNUSTEP_SYSTEM_ROOT}/Library/Documentation/Developer/Renaissance
+ mv ${D}$(egnustep_install_domain)/Library/Documentation/* ${TMP}/tmpdocs
+ mkdir -p ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
+ mv ${TMP}/tmpdocs/* ${D}$(egnustep_install_domain)/Library/Documentation/Developer/Renaissance
cd ..
fi
egnustep_package_config