summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2010-03-06 17:57:02 +0000
committerAngelo Arrifano <miknix@gentoo.org>2010-03-06 17:57:02 +0000
commit61371a1d77c2c1e5ba6b75a3ff5ffde29783d28f (patch)
treee1407a25c5cf229030f3dc36463dea0d2ed0d064 /gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild
parentImport upstream patch to fix building wrt #298671, thanks to Kacper Kowalik a... (diff)
downloadhistorical-61371a1d77c2c1e5ba6b75a3ff5ffde29783d28f.tar.gz
historical-61371a1d77c2c1e5ba6b75a3ff5ffde29783d28f.tar.bz2
historical-61371a1d77c2c1e5ba6b75a3ff5ffde29783d28f.zip
Import from GPE overlay.
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild')
-rw-r--r--gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild b/gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild
new file mode 100644
index 000000000000..8dcdd14e6e01
--- /dev/null
+++ b/gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gpe-utils/gpe-plucker/gpe-plucker-0.4.ebuild,v 1.1 2010/03/06 17:57:02 miknix Exp $
+
+inherit eutils gpe
+
+DESCRIPTION="Plucker ebook reader for the GPE Palmtop Environment"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ gpe-base/libgpewidget"
+DEPEND="${DEPEND}
+ ${RDEPEND}"
+
+GPE_DOCS="Changelog README README-GPE ToDo"
+
+src_unpack() {
+ gpe_src_unpack "$@"
+
+ # This package doesn't currrently support autotools
+ mv -f gpe-plucker.desktop.in gpe-plucker.desktop
+ sed -i -e 's/^_//' gpe-plucker.desktop || die "desktop sed fail"
+
+ # nls not supported on this pkg
+ sed -i -e 's;include $(BUILD)/Makefile.translation;;' Makefile \
+ || die "Makefile sed fail"
+}