summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:01:56 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 21:01:56 +0000
commit99cf34edaf035d1e1c226b94682c9f63b5e8cc14 (patch)
tree7064b2edf0eb28b5944519b73481fa92ad89bb4b /kde-base/dolphin
parentAdded the KDE 4.0.5 version of cervisia. (diff)
downloadhistorical-99cf34edaf035d1e1c226b94682c9f63b5e8cc14.tar.gz
historical-99cf34edaf035d1e1c226b94682c9f63b5e8cc14.tar.bz2
historical-99cf34edaf035d1e1c226b94682c9f63b5e8cc14.zip
Added the KDE 4.0.5 version of dolphin.
Package-Manager: portage-2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog8
-rw-r--r--kde-base/dolphin/dolphin-4.0.5.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index bb6b539f5042..ebae16e93c86 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.9 2008/05/30 08:32:35 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.10 2008/06/05 21:01:56 keytoaster Exp $
+
+*dolphin-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +dolphin-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of dolphin.
30 May 2008; Bo Ørsted Andresen <zlin@gentoo.org> dolphin-4.0.4.ebuild:
KDE4_BUILT_WITH_USE_CHECK is now always an array. Bug #216863.
diff --git a/kde-base/dolphin/dolphin-4.0.5.ebuild b/kde-base/dolphin/dolphin-4.0.5.ebuild
new file mode 100644
index 000000000000..051582b7cd4e
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.0.5.ebuild,v 1.1 2008/06/05 21:01:56 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+PATCHES=("${FILESDIR}/${PN}-4.0.2-make-semantic-desktop-optional.patch")
+
+pkg_setup() {
+ if use semantic-desktop; then
+ KDE4_BUILT_WITH_USE_CHECK=("--missing false kde-base/kdelibs:${SLOT} semantic-desktop")
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_compile
+}