summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb7e10b1ff43fba2e87d10b1de1b37a907f25a32d (patch)
tree991d07389d560eb2828b10508e6ca8022fb6c212 /kde-base/kalzium
parentStable for HPPA (bug #444546). (diff)
downloadhistorical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.tar.gz
historical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.tar.bz2
historical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.zip
[kde-base] Add KDE SC 4.9.4
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64 Manifest-Sign-Key: 0xF82F92E6
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.9.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index a3dbd908cc70..f3fce9c6049c 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.244 2012/11/30 15:23:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.245 2012/12/05 16:58:14 alexxy Exp $
+
+*kalzium-4.9.4 (05 Dec 2012)
+
+ 05 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +kalzium-4.9.4.ebuild:
+ Version bump KDE SC 4.9.4
30 Nov 2012; <ago@gentoo.org> kalzium-4.9.3.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/kde-base/kalzium/kalzium-4.9.4.ebuild b/kde-base/kalzium/kalzium-4.9.4.ebuild
new file mode 100644
index 000000000000..5820bdb5444e
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.9.4.ebuild,v 1.1 2012/12/05 16:58:14 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="editor debug +plasma solver"
+
+RDEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${RDEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3:2 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ mycmakeargs=(
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}