summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commit3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe (patch)
tree354eb455031cc91369bff38098f7636aa38ecdad /kde-base/kdeplasma-addons
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadhistorical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.gz
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.bz2
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.zip
[kde-base] Add KDE SC 4.6.0
Package-Manager: portage-2.2.0_alpha19_p2/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/files/kdeplasma-addons-4.5.56-cmake.patch47
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.6.0.ebuild76
3 files changed, 130 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 4bb76c5291da..920ec063e463 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.77 2011/01/10 11:53:29 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.78 2011/01/26 20:29:23 alexxy Exp $
+
+*kdeplasma-addons-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +files/kdeplasma-addons-4.5.56-cmake.patch, +kdeplasma-addons-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*kdeplasma-addons-4.5.5 (10 Jan 2011)
diff --git a/kde-base/kdeplasma-addons/files/kdeplasma-addons-4.5.56-cmake.patch b/kde-base/kdeplasma-addons/files/kdeplasma-addons-4.5.56-cmake.patch
new file mode 100644
index 000000000000..1e326a517045
--- /dev/null
+++ b/kde-base/kdeplasma-addons/files/kdeplasma-addons-4.5.56-cmake.patch
@@ -0,0 +1,47 @@
+Index: applets/CMakeLists.txt
+===================================================================
+--- applets/CMakeLists.txt (revision 1172136)
++++ applets/CMakeLists.txt (working copy)
+@@ -16,6 +16,7 @@
+ add_subdirectory(calculator)
+ add_subdirectory(charselect)
+ add_subdirectory(comic)
++add_subdirectory(dict)
+ add_subdirectory(fifteenPuzzle)
+ add_subdirectory(fileWatcher)
+ add_subdirectory(frame)
+@@ -30,14 +31,21 @@
+ add_subdirectory(microblog)
+ add_subdirectory(notes)
+ add_subdirectory(nowplaying)
++
+ if(LIBATTICA_FOUND)
+ add_subdirectory(community)
+ add_subdirectory(social-news)
+ endif(LIBATTICA_FOUND)
++
+ add_subdirectory(pastebin)
+ add_subdirectory(previewer)
+ add_subdirectory(rememberthemilk)
+-add_subdirectory(rssnow)
++
++if(KDEPIMLIBS_FOUND)
++ add_subdirectory(news)
++ add_subdirectory(rssnow)
++endif(KDEPIMLIBS_FOUND)
++
+ add_subdirectory(spellcheck)
+ add_subdirectory(showdashboard)
+ add_subdirectory(timer)
+@@ -48,11 +56,6 @@
+ add_subdirectory(weatherstation)
+ add_subdirectory(weather)
+
+-if(QT_QTWEBKIT_FOUND)
+- add_subdirectory(dict)
+- add_subdirectory(news)
+-endif(QT_QTWEBKIT_FOUND)
+-
+ if(PHONON_FOUND)
+ add_subdirectory(mediaplayer)
+ endif(PHONON_FOUND)
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.0.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.0.ebuild
new file mode 100644
index 000000000000..a3358c27342b
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.6.0.ebuild,v 1.1 2011/01/26 20:29:23 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeplasma-addons"
+WEBKIT_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines."
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug desktopglobe exif qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ dev-libs/libattica
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace)
+ x11-misc/shared-mime-info
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+# kde-misc/plasmaboard: moved here in 4.3.65
+# kde-misc/qalculate-applet: since 4.4.0
+RDEPEND="${COMMON_DEPEND}
+ !kdeprefix? (
+ !kde-misc/plasmaboard
+ !kde-misc/qalculate-applet
+ )
+"
+
+# kdebase-data: some svg icons moved from data directly here.
+add_blocker kdebase-data '<4.2.88'
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.5.56-cmake.patch"
+)
+
+src_prepare() {
+ find "${S}" -name CMakeLists.txt | \
+ xargs sed -i \
+ -e 's/${KDE4WORKSPACE_PLASMACLOCK_LIBRARY}/plasmaclock/g' \
+ -e 's/${KDE4WORKSPACE_WEATHERION_LIBRARY}/weather_ion/g' \
+ -e 's/${KDE4WORKSPACE_TASKMANAGER_LIBRARY}/taskmanager/g' \
+ || die "Failed to patch CMake files"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EKDEDIR}/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}