summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-11 00:07:10 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-11 00:07:10 +0000
commit7d230fcd1e93cc9b3925ccc230cc470effb56dea (patch)
tree357908cfce1aa7466aefe4803c167bfd1cd69d63 /kde-base/kdesu
parentAdded sys-apps/findutils to RDEPEND since find/xargs are used by the bootmisc... (diff)
downloadhistorical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.tar.gz
historical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.tar.bz2
historical-7d230fcd1e93cc9b3925ccc230cc470effb56dea.zip
Version bump to KDE 4.0.2.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kdesu')
-rw-r--r--kde-base/kdesu/ChangeLog7
-rw-r--r--kde-base/kdesu/kdesu-4.0.2.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/kde-base/kdesu/ChangeLog b/kde-base/kdesu/ChangeLog
index 3000487de51e..5ea874aa96a4 100644
--- a/kde-base/kdesu/ChangeLog
+++ b/kde-base/kdesu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdesu
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/ChangeLog,v 1.80 2008/03/04 02:38:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/ChangeLog,v 1.81 2008/03/10 23:36:06 philantrop Exp $
+
+*kdesu-4.0.2 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> +kdesu-4.0.2.ebuild:
+ Version bump to KDE 4.0.2
04 Mar 2008; Jeroen Roovers <jer@gentoo.org> kdesu-3.5.8.ebuild,
kdesu-3.5.9.ebuild, kdesu-4.0.1.ebuild:
diff --git a/kde-base/kdesu/kdesu-4.0.2.ebuild b/kde-base/kdesu/kdesu-4.0.2.ebuild
new file mode 100644
index 000000000000..ee8687db0a44
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.0.2.ebuild,v 1.1 2008/03/10 23:36:06 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-runtime
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook"
+
+src_compile() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_compile
+}