summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kghostview
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kghostview')
-rw-r--r--kde-base/kghostview/ChangeLog8
-rw-r--r--kde-base/kghostview/kghostview-3.5.9.ebuild25
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-base/kghostview/ChangeLog b/kde-base/kghostview/ChangeLog
index 20bf0a7f0942..dff4ed209502 100644
--- a/kde-base/kghostview/ChangeLog
+++ b/kde-base/kghostview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kghostview
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kghostview/ChangeLog,v 1.83 2008/02/17 02:47:03 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kghostview/ChangeLog,v 1.84 2008/02/20 23:00:42 philantrop Exp $
+
+*kghostview-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kghostview-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kghostview-3.5.5.ebuild, -kghostview-3.5.6.ebuild,
diff --git a/kde-base/kghostview/kghostview-3.5.9.ebuild b/kde-base/kghostview/kghostview-3.5.9.ebuild
new file mode 100644
index 000000000000..62bac4c427d9
--- /dev/null
+++ b/kde-base/kghostview/kghostview-3.5.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kghostview/kghostview-3.5.9.ebuild,v 1.1 2008/02/20 23:00:42 philantrop Exp $
+
+KMNAME=kdegraphics
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE: Viewer for PostScript (.ps, .eps) and Portable Document Format (.pdf) files"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+# /Should/ also rdepend on kdeprint. Since kdeprint rdepends on kghostview for previews, we'd had a conflict, so we can't.
+RDEPEND="virtual/ghostscript"
+KMEXTRA="kfile-plugins/ps"
+
+pkg_setup() {
+ kde_pkg_setup
+ for ghostscript in app-text/ghostscript-{gnu,esp,afpl}; do
+ if has_version ${ghostscript} && ! built_with_use ${ghostscript} X; then
+ eerror "This package requires ${ghostscript} compiled with X11 support."
+ eerror "Please reemerge ${ghostscript} with USE=\"X\"."
+ die "Please reemerge ${ghostscript} with USE=\"X\"."
+ fi
+ done
+}