summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:21:21 +0000
committerBo Ørsted Andresen <zlin@gentoo.org>2008-01-27 15:21:21 +0000
commit481d45e1c8172df207d10383e300bb6cf46cf4ab (patch)
tree032b3291e4a9888c86c098eb2ff6d0eb462658de /kde-base/krunner/files
parentMarking wxpython-2.6.4.0-r1 and wxpython-2.8.7.1 ppc64 stable per bug 207648 (diff)
downloadhistorical-481d45e1c8172df207d10383e300bb6cf46cf4ab.tar.gz
historical-481d45e1c8172df207d10383e300bb6cf46cf4ab.tar.bz2
historical-481d45e1c8172df207d10383e300bb6cf46cf4ab.zip
Fix compilation with USE=-opengl. For bug #206517.
Package-Manager: portage-2.1.4
Diffstat (limited to 'kde-base/krunner/files')
-rw-r--r--kde-base/krunner/files/krunner-4.0.0-opengl.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/kde-base/krunner/files/krunner-4.0.0-opengl.patch b/kde-base/krunner/files/krunner-4.0.0-opengl.patch
new file mode 100644
index 000000000000..7ab619e561ae
--- /dev/null
+++ b/kde-base/krunner/files/krunner-4.0.0-opengl.patch
@@ -0,0 +1,23 @@
+--- workspace/CMakeLists.txt (revision 767202)
++++ workspace/CMakeLists.txt (working copy)
+@@ -16,8 +16,6 @@
+ include (MacroLibrary)
+ include (KDE4Defaults)
+
+-macro_optional_find_package(OpenGL)
+-
+ include(ConfigureChecks.cmake)
+ configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
+--- workspace/krunner/lock/CMakeLists.txt (revision 766878)
++++ workspace/krunner/lock/CMakeLists.txt (working copy)
+@@ -5,7 +5,9 @@
+ ########### next target ###############
+
+ check_library_exists(Xxf86misc XF86MiscSetGrabKeysState "" HAVE_XF86MISCSETGRABKEYSSTATE)
++if(WITH_OpenGL)
+ check_library_exists(GL glXChooseVisual "" HAVE_GLXCHOOSEVISUAL)
++endif(WITH_OpenGL)
+
+ configure_file(config-krunner-lock.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-krunner-lock.h)
+