summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-12-11 18:52:41 +0000
commit351f7dda3f62817dd3747226a48fb58b92f8e510 (patch)
treed44f25d056ad34656ac0a5ac45ee7fa316af0df4 /kde-base/ksysguard
parentAdd 3.0 documentation (diff)
downloadhistorical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.gz
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.tar.bz2
historical-351f7dda3f62817dd3747226a48fb58b92f8e510.zip
[kde-base] Add long waiting KDE SC 4.7.4
Package-Manager: portage-2.2.0_alpha79/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.7.4.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index d6a5724470fc..32550336a567 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.224 2011/12/07 23:07:51 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.225 2011/12/11 18:52:17 alexxy Exp $
+
+*ksysguard-4.7.4 (11 Dec 2011)
+
+ 11 Dec 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksysguard-4.7.4.ebuild:
+ Version bump KDE SC 4.7.4
07 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
-ksysguard-4.7.2.ebuild:
diff --git a/kde-base/ksysguard/ksysguard-4.7.4.ebuild b/kde-base/ksysguard/ksysguard-4.7.4.ebuild
new file mode 100644
index 000000000000..90a7b7481f97
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.7.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.7.4.ebuild,v 1.1 2011/12/11 18:52:17 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}