summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit4816953d7b880b98d593a026f8417178af0c61d9 (patch)
treef2e62f96dd734dff956565c230831b7cc368b4f5 /kde-base/ksystemlog
parentVersion bump. Remove intermediate version. (diff)
downloadhistorical-4816953d7b880b98d593a026f8417178af0c61d9.tar.gz
historical-4816953d7b880b98d593a026f8417178af0c61d9.tar.bz2
historical-4816953d7b880b98d593a026f8417178af0c61d9.zip
Version bump to KDE SC 4.6.3.
Package-Manager: portage-2.2.0_alpha31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog8
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.6.3.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 368b5dfee952..377b6be2b422 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.68 2011/04/06 14:19:05 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.69 2011/05/07 10:47:44 scarabeus Exp $
+
+*ksystemlog-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +ksystemlog-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
*ksystemlog-4.6.2 (06 Apr 2011)
diff --git a/kde-base/ksystemlog/ksystemlog-4.6.3.ebuild b/kde-base/ksystemlog/ksystemlog-4.6.3.ebuild
new file mode 100644
index 000000000000..8c5d0e52f949
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.6.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.6.3.ebuild,v 1.1 2011/05/07 10:47:44 scarabeus Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}