summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
commit884448fe539d8d03e15d3b454fb0413fe9b6fbbc (patch)
tree1f45a51ef736830a005781f5a511fee20d294f84 /kde-base/kwin
parentFixup 4.1.3 mask, so no more empty lines. (diff)
downloadhistorical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.gz
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.bz2
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.zip
Full auto: Version bump for KDE-4.1.3
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-gentoo i686
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.1.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 6187dc632637..57b8910719fc 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.133 2008/10/21 11:28:20 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.134 2008/11/09 02:19:24 scarabeus Exp $
+
+*kwin-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +kwin-4.1.3.ebuild:
+ Version bump.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-kwin-4.0.4.ebuild, -kwin-4.0.4-r1.ebuild, -kwin-4.0.5.ebuild:
diff --git a/kde-base/kwin/kwin-4.1.3.ebuild b/kde-base/kwin/kwin-4.1.3.ebuild
new file mode 100644
index 000000000000..5265aa0597b7
--- /dev/null
+++ b/kde-base/kwin/kwin-4.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.1.3.ebuild,v 1.1 2008/11/09 02:19:24 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="captury debug opengl xcomposite xinerama"
+
+COMMONDEPEND="
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}