summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-17 03:31:00 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-17 03:31:00 +0000
commit1f0d82e30a76e7b698e006c0b23ef4ba43d716db (patch)
tree71740acf58d3dc2cadad8ebbfe1669f80226a1ea /kde-base/libkcal
parentSpring Cleaning (diff)
downloadhistorical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.tar.gz
historical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.tar.bz2
historical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.zip
Spring cleaning.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/libkcal')
-rw-r--r--kde-base/libkcal/ChangeLog8
-rw-r--r--kde-base/libkcal/files/libkcal-3.5.7-recurring_194371.patch256
-rw-r--r--kde-base/libkcal/libkcal-3.5.5-r1.ebuild27
-rw-r--r--kde-base/libkcal/libkcal-3.5.5.ebuild19
-rw-r--r--kde-base/libkcal/libkcal-3.5.6-r1.ebuild27
-rw-r--r--kde-base/libkcal/libkcal-3.5.6.ebuild19
-rw-r--r--kde-base/libkcal/libkcal-3.5.7-r1.ebuild27
-rw-r--r--kde-base/libkcal/libkcal-3.5.7-r2.ebuild29
-rw-r--r--kde-base/libkcal/libkcal-3.5.7.ebuild24
9 files changed, 7 insertions, 429 deletions
diff --git a/kde-base/libkcal/ChangeLog b/kde-base/libkcal/ChangeLog
index 2504e546d5d3..8b3d2a0982e0 100644
--- a/kde-base/libkcal/ChangeLog
+++ b/kde-base/libkcal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/libkcal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/ChangeLog,v 1.92 2008/01/31 15:27:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/ChangeLog,v 1.93 2008/02/17 01:58:48 ingmar Exp $
+
+ 16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ -files/libkcal-3.5.7-recurring_194371.patch, -libkcal-3.5.5.ebuild,
+ -libkcal-3.5.5-r1.ebuild, -libkcal-3.5.6.ebuild, -libkcal-3.5.6-r1.ebuild,
+ -libkcal-3.5.7.ebuild, -libkcal-3.5.7-r1.ebuild, -libkcal-3.5.7-r2.ebuild:
+ Spring cleaning
31 Jan 2008; Brent Baude <ranger@gentoo.org> libkcal-3.5.8.ebuild:
Marking libkcal-3.5.8 ppc for bug 207634
diff --git a/kde-base/libkcal/files/libkcal-3.5.7-recurring_194371.patch b/kde-base/libkcal/files/libkcal-3.5.7-recurring_194371.patch
deleted file mode 100644
index 990b09408d89..000000000000
--- a/kde-base/libkcal/files/libkcal-3.5.7-recurring_194371.patch
+++ /dev/null
@@ -1,256 +0,0 @@
---- branches/KDE/3.5/kdepim/libkcal/calendarlocal.cpp 2007/10/01 17:04:23 719674
-+++ branches/KDE/3.5/kdepim/libkcal/calendarlocal.cpp 2007/10/01 17:04:57 719675
-@@ -401,62 +401,75 @@
- bool inclusive )
- {
- Event::List eventList;
-+ QDate yesterStart = start.addDays(-1);
-
- // Get non-recurring events
- EventDictIterator it( mEvents );
- for( ; it.current(); ++it ) {
- Event *event = *it;
-- if ( event->doesRecur() ) {
-- QDate rStart = event->dtStart().date();
-- bool found = false;
-- if ( inclusive ) {
-- if ( rStart >= start && rStart <= end ) {
-- // Start date of event is in range. Now check for end date.
-- // if duration is negative, event recurs forever, so do not include it.
-- if ( event->recurrence()->duration() == 0 ) { // End date set
-- QDate rEnd = event->recurrence()->endDate();
-- if ( rEnd >= start && rEnd <= end ) { // End date within range
-- found = true;
-- }
-- } else if ( event->recurrence()->duration() > 0 ) { // Duration set
-- // TODO: Calculate end date from duration. Should be done in Event
-- // For now exclude all events with a duration.
-+
-+ QDate rStart = event->dtStart().date();
-+ if (end < rStart) {
-+ kdDebug(5800) << "Skipping event starting after TOI" << endl;
-+ continue;
-+ }
-+ if ( inclusive && rStart < start) {
-+ kdDebug(5800) << "Skipping event starting before TOI while inclusive" << endl;
-+ continue;
-+ }
-+
-+ if ( ! event->doesRecur() ) { // non-recurring events
-+ QDate rEnd = event->dtEnd().date();
-+ if (rEnd < start) {
-+ kdDebug(5800) << "Skipping event ending before TOI" << endl;
-+ continue;
-+ }
-+ if ( inclusive && end < rEnd ) {
-+ kdDebug(5800) << "Skipping event ending after TOI while inclusive" << endl;
-+ continue;
-+ }
-+ } else { // recurring events
-+ switch ( event->recurrence()->duration() ) {
-+ case -1: // infinite
-+ if ( inclusive ) {
-+ kdDebug(5800) << "Skipping infinite event because inclusive" << endl;
-+ continue;
- }
-- }
-- } else {
-- if ( rStart <= end ) { // Start date not after range
-- if ( rStart >= start ) { // Start date within range
-- found = true;
-- } else if ( event->recurrence()->duration() == -1 ) { // Recurs forever
-- found = true;
-- } else if ( event->recurrence()->duration() == 0 ) { // End date set
-- QDate rEnd = event->recurrence()->endDate();
-- if ( rEnd >= start && rEnd <= end ) { // End date within range
-- found = true;
-- }
-- } else { // Duration set
-- // TODO: Calculate end date from duration. Should be done in Event
-- // For now include all events with a duration.
-- found = true;
-+ break;
-+ case 0: // end date given
-+ default: // count given
-+ QDate rEnd = event->recurrence()->endDate();
-+ if ( ! rEnd.isValid() ) {
-+ kdDebug(5800) << "Skipping recurring event without occurences" << endl;
-+ continue;
- }
-- }
-- }
-+ if ( rEnd < start ) {
-+ kdDebug(5800) << "Skipping recurring event ending before TOI" << endl;
-+ continue;
-+ }
-+ if ( inclusive && end < rEnd ) {
-+ kdDebug(5800) << "Skipping recurring event ending after TOI while inclusive" << endl;
-+ continue;
-+ }
-+ /* FIXME: too much conversion between QDate and QDateTime makes this useless:
-+ * freebusy(end=QDateTime(day, "00:00:00")) ->
-+ * rawEvents(end=QDate(day)) ->
-+ * durationTo(QDateTime(day, "23:59:59"))
-+ * so events repeating at the end day match and are included.
-+ */
-+#if 0
-+ int durationBeforeStart = event->recurrence()->durationTo(yesterStart);
-+ int durationUntilEnd = event->recurrence()->durationTo(end);
-+ if (durationBeforeStart == durationUntilEnd) {
-+ kdDebug(5800) << "Skipping recurring event without occurences in TOI" << endl;
-+ continue;
-+ }
-+#endif
-+ break;
-+ } // switch(duration)
-+ } // if(doesRecur)
-
-- if ( found ) eventList.append( event );
-- } else {
-- QDate s = event->dtStart().date();
-- QDate e = event->dtEnd().date();
--
-- if ( inclusive ) {
-- if ( s >= start && e <= end ) {
-- eventList.append( event );
-- }
-- } else {
-- if ( s <= end && e >= start ) {
-- eventList.append( event );
-- }
-- }
-- }
-+ eventList.append( event );
- }
-
- return eventList;
---- branches/KDE/3.5/kdepim/libkcal/recurrencerule.cpp 2007/10/01 17:04:23 719674
-+++ branches/KDE/3.5/kdepim/libkcal/recurrencerule.cpp 2007/10/01 17:04:57 719675
-@@ -558,28 +558,22 @@
- setDirty();
- }
-
--
- QDateTime RecurrenceRule::endDt( bool *result ) const
- {
- if ( result ) *result = false;
- if ( mPeriod == rNone ) return QDateTime();
-- if ( mDuration < 0 ) {
-- if ( result ) result = false;
-- return QDateTime();
-- } else if ( mDuration == 0 ) {
-+ if ( mDuration < 0 ) return QDateTime();
-+ if ( mDuration == 0 ) {
-+ if ( result ) *result = true;
- return mDateEnd;
-- } else {
-- // N occurrences. Check if we have a full cache. If so, return the cached end date.
-- if ( ! mCached ) {
-- // If not enough occurrences can be found (i.e. inconsistent constraints)
-- if ( !buildCache() ) {
-- if ( result ) result = false;
-- return QDateTime();
-- }
-- }
-- return mCachedDateEnd;
- }
-- return QDateTime();
-+ // N occurrences. Check if we have a full cache. If so, return the cached end date.
-+ if ( ! mCached ) {
-+ // If not enough occurrences can be found (i.e. inconsistent constraints)
-+ if ( !buildCache() ) return QDateTime();
-+ }
-+ if ( result ) *result = true;
-+ return mCachedDateEnd;
- }
-
- void RecurrenceRule::setEndDt( const QDateTime &dateTime )
---- branches/KDE/3.5/kdepim/libkcal/tests/Makefile.am 2007/10/01 17:04:23 719674
-+++ branches/KDE/3.5/kdepim/libkcal/tests/Makefile.am 2007/10/01 17:04:57 719675
-@@ -4,6 +4,7 @@
- check_PROGRAMS = testtostring \
- testincidence \
- testcalendar \
-+ fbrecurring \
- readandwrite \
- testresource \
- testfields \
-@@ -28,6 +29,10 @@
- testtostring_LDFLAGS = $(all_libraries) $(KDE_RPATH)
- testtostring_LDADD = ../libkcal.la
-
-+fbrecurring_SOURCES = fbrecurring.cpp
-+fbrecurring_LDFLAGS = $(all_libraries) $(KDE_RPATH)
-+fbrecurring_LDADD = ../libkcal.la
-+
- readandwrite_SOURCES = readandwrite.cpp
- readandwrite_LDFLAGS = $(all_libraries) $(KDE_RPATH)
- readandwrite_LDADD = ../libkcal.la
-@@ -78,10 +83,10 @@
- perl $(srcdir)/runtestcase.pl readandwrite "ical" $$i; \
- done; \
- for i in `find $(srcdir)/data/vCalendar/ -name "*.ics"`; do \
-- perl $(srcdir)/runtestcase.pl testvcalexport "vcal" $$i; \
-+ perl $(srcdir)/runtestcase.pl testvcalexport "vcal" $$i; \
- done;
- for i in `find $(srcdir)/data/vCalendar/ -name "*.vcs"`; do \
-- perl $(srcdir)/runtestcase.pl readandwrite "ical" $$i; \
-+ perl $(srcdir)/runtestcase.pl readandwrite "ical" $$i; \
- done;
- [ ! -e FAILED ]
-
---- branches/KDE/3.5/kdepim/libkcal/tests.orig/fbrecurring.cpp 2007-08-31 20:52:15.220373203 +0200
-+++ branches/KDE/3.5/kdepim/libkcal/tests/fbrecurring.cpp 2007-10-04 19:53:52.000000000 +0200
-@@ -0,0 +1,52 @@
-+
-+#include "icalformat.h"
-+#include "event.h"
-+#include "calendarlocal.h"
-+
-+#include <libkcal/freebusy.h>
-+#include <iostream>
-+
-+using namespace KCal;
-+using namespace std;
-+
-+int main()
-+{
-+ ICalFormat f;
-+
-+ CalendarLocal cal( QString::fromLatin1("UTC") );
-+
-+ Event *event1 = new Event;
-+ event1->setSummary("A");
-+ event1->setDtStart( QDateTime(QDate(2006,1,1), QTime(12,0,0)) );
-+ //event1->setDuration(60*60);
-+ event1->setDtEnd( QDateTime(QDate(2006,1,1), QTime(13,0,0)) );
-+ event1->setFloats(FALSE);
-+ event1->recurrence()->setDaily( 1 );
-+ //event1->recurrence()->setDuration( 2 );
-+ event1->recurrence()->setEndDateTime( QDateTime(QDate(2006,1,3), QTime(13,0,0)) );
-+ cout << f.toICalString(event1).latin1() << endl;
-+ cal.addEvent(event1);
-+
-+ Event *event2 = new Event;
-+ event2->setSummary("B");
-+ event2->setDtStart( QDateTime(QDate(2006,1,1), QTime(13,0,0)) );
-+ //event2->setDuration(60*60);
-+ event2->setDtEnd( QDateTime(QDate(2006,1,1), QTime(14,0,0)) );
-+ event2->setFloats(FALSE);
-+ event2->recurrence()->setDaily( 1 );
-+ //event2->recurrence()->setDuration( 3 );
-+ event2->recurrence()->setEndDateTime( QDateTime(QDate(2006,1,4), QTime(13,0,0)) );
-+ cout << f.toICalString(event2).latin1() << endl;
-+ cal.addEvent(event2);
-+
-+ Calendar *c = &cal;
-+
-+ QDateTime start = QDateTime(QDate(2006,1,2), QTime(0,0,0));
-+ QDateTime end = QDateTime(QDate(2006,1,3), QTime(0,0,0));
-+
-+ FreeBusy *freebusy = new FreeBusy( c, start, end );
-+ QString result = f.createScheduleMessage( freebusy, Scheduler::Publish );
-+ cout << result.latin1() << endl;
-+
-+ return 0;
-+}
diff --git a/kde-base/libkcal/libkcal-3.5.5-r1.ebuild b/kde-base/libkcal/libkcal-3.5.5-r1.ebuild
deleted file mode 100644
index 9b74a19d8c06..000000000000
--- a/kde-base/libkcal/libkcal-3.5.5-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.5-r1.ebuild,v 1.8 2007/04/24 10:59:32 kloeri Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
-
-DESCRIPTION="KDE kcal library for korganizer etc"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
-
-src_unpack() {
- kde-meta_src_unpack
- sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am
-}
diff --git a/kde-base/libkcal/libkcal-3.5.5.ebuild b/kde-base/libkcal/libkcal-3.5.5.ebuild
deleted file mode 100644
index d5329bfa0c4c..000000000000
--- a/kde-base/libkcal/libkcal-3.5.5.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.5.ebuild,v 1.8 2006/12/11 19:06:30 kloeri Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-DESCRIPTION="KDE kcal library for korganizer etc"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
diff --git a/kde-base/libkcal/libkcal-3.5.6-r1.ebuild b/kde-base/libkcal/libkcal-3.5.6-r1.ebuild
deleted file mode 100644
index 39002aa5fae5..000000000000
--- a/kde-base/libkcal/libkcal-3.5.6-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.6-r1.ebuild,v 1.2 2007/04/12 19:18:45 mr_bones_ Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/kdepim-3.5-patchset-03.tar.bz2"
-
-DESCRIPTION="KDE kcal library for KOrganizer etc"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
-
-src_unpack() {
- kde-meta_src_unpack
- sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am
-}
diff --git a/kde-base/libkcal/libkcal-3.5.6.ebuild b/kde-base/libkcal/libkcal-3.5.6.ebuild
deleted file mode 100644
index bb0521701e40..000000000000
--- a/kde-base/libkcal/libkcal-3.5.6.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.6.ebuild,v 1.1 2007/01/16 21:48:20 flameeyes Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-DESCRIPTION="KDE kcal library for korganizer etc"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
diff --git a/kde-base/libkcal/libkcal-3.5.7-r1.ebuild b/kde-base/libkcal/libkcal-3.5.7-r1.ebuild
deleted file mode 100644
index fa75b4ef372f..000000000000
--- a/kde-base/libkcal/libkcal-3.5.7-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.7-r1.ebuild,v 1.7 2007/08/11 16:56:46 armin76 Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
-
-DESCRIPTION="KDE kcal library for KOrganizer etc"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
-
-src_unpack() {
- kde-meta_src_unpack
- sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am
-}
diff --git a/kde-base/libkcal/libkcal-3.5.7-r2.ebuild b/kde-base/libkcal/libkcal-3.5.7-r2.ebuild
deleted file mode 100644
index 50f7f09cbb3a..000000000000
--- a/kde-base/libkcal/libkcal-3.5.7-r2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.7-r2.ebuild,v 1.1 2007/10/04 19:15:39 philantrop Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-SRC_URI="${SRC_URI}
- mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
-
-DESCRIPTION="KDE kcal library for KOrganizer etc"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
-
-PATCHES="${FILESDIR}/${P}-recurring_194371.patch"
-
-src_unpack() {
- kde-meta_src_unpack
- sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am
-}
diff --git a/kde-base/libkcal/libkcal-3.5.7.ebuild b/kde-base/libkcal/libkcal-3.5.7.ebuild
deleted file mode 100644
index 8d7915336947..000000000000
--- a/kde-base/libkcal/libkcal-3.5.7.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcal/libkcal-3.5.7.ebuild,v 1.1 2007/05/23 02:12:46 carlo Exp $
-
-KMNAME=kdepim
-MAXKDEVER=$PV
-KM_DEPRANGE="$PV $MAXKDEVER"
-inherit kde-meta eutils
-
-DESCRIPTION="KDE kcal library for KOrganizer etc"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND="$(deprange $PV $MAXKDEVER kde-base/ktnef)"
-RDEPEND="${DEPEND}"
-
-KMCOPYLIB="libktnef ktnef/lib"
-KMEXTRACTONLY="libkdepim/email.h"
-KMCOMPILEONLY="libemailfunctions/"
-
-src_unpack() {
- kde-meta_src_unpack
- sed -e "s:SUBDIRS = libical versit tests:SUBDIRS = libical versit:" -i libkcal/Makefile.am
-}