summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/noatun-plugins
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/noatun-plugins')
-rw-r--r--kde-base/noatun-plugins/ChangeLog8
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.9.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index 5e74c9fa014f..1de09f55103c 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.81 2008/02/17 02:18:36 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.82 2008/02/20 23:34:11 philantrop Exp $
+
+*noatun-plugins-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +noatun-plugins-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-noatun-plugins-3.5.5.ebuild, -noatun-plugins-3.5.6.ebuild,
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.9.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.9.ebuild
new file mode 100644
index 000000000000..6437ab4e90eb
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.9.ebuild,v 1.1 2008/02/20 23:34:11 philantrop Exp $
+KMNAME=kdeaddons
+EAPI="1"
+inherit db-use kde-meta
+
+DESCRIPTION="Various plugins for Noatun."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="arts sdl berkdb"
+
+DEPEND=">=kde-base/noatun-${PV}:${SLOT}
+ arts? ( >=kde-base/arts-${PV}:${SLOT} )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( =sys-libs/db-4* )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ kde_pkg_setup
+ if use sdl && ! built_with_use media-libs/libsdl X ; then
+ eerror "media-libs/libsdl is not build with X support."
+ die "Please reemerge media-libs/libsdl with USE=\"X\"."
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_with sdl)"
+
+ if use berkdb; then
+ dblib="$(db_libname)"
+ myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
+ --with-extra-includes=${ROOT}$(db_includedir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde-meta_src_compile
+}