summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/okular
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.9.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 074ace6d7965..7210221d7ae2 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.153 2012/09/03 13:29:57 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.154 2012/09/04 18:45:35 johu Exp $
+
+*okular-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +okular-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org> -okular-4.7.4.ebuild:
Remove KDE SC 4.7.4
diff --git a/kde-base/okular/okular-4.9.1.ebuild b/kde-base/okular/okular-4.9.1.ebuild
new file mode 100644
index 000000000000..2a4b5a9d2b52
--- /dev/null
+++ b/kde-base/okular/okular-4.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.9.1.ebuild,v 1.1 2012/09/04 18:45:35 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}