summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-07 20:14:08 +0000
commit5f9a89edfc761f6e642eaf86247fccacdd48d248 (patch)
treed6c5667c5d199a8f311d21b4e1273d740f0b4d06 /kde-base/perlqt
parent[profiles] Update kde mask (diff)
downloadhistorical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.gz
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.tar.bz2
historical-5f9a89edfc761f6e642eaf86247fccacdd48d248.zip
[kde-base] Add KDE SC 4.7.1
Package-Manager: portage-2.2.0_alpha54/cvs/Linux x86_64
Diffstat (limited to 'kde-base/perlqt')
-rw-r--r--kde-base/perlqt/ChangeLog7
-rw-r--r--kde-base/perlqt/perlqt-4.7.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/perlqt/ChangeLog b/kde-base/perlqt/ChangeLog
index 7465b6fe82a4..e96c88521df0 100644
--- a/kde-base/perlqt/ChangeLog
+++ b/kde-base/perlqt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/perlqt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.2 2011/08/03 20:59:53 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/ChangeLog,v 1.3 2011/09/07 20:14:06 alexxy Exp $
+
+*perlqt-4.7.1 (07 Sep 2011)
+
+ 07 Sep 2011; Alexey Shvetsov <alexxy@gentoo.org> +perlqt-4.7.1.ebuild:
+ Version bump KDE SC 4.7.1
03 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org> perlqt-4.7.0.ebuild:
Fix tests, bug 376955
diff --git a/kde-base/perlqt/perlqt-4.7.1.ebuild b/kde-base/perlqt/perlqt-4.7.1.ebuild
new file mode 100644
index 000000000000..3cec774cf249
--- /dev/null
+++ b/kde-base/perlqt/perlqt-4.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/perlqt/perlqt-4.7.1.ebuild,v 1.1 2011/09/07 20:14:06 alexxy Exp $
+
+EAPI=4
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Qt Perl bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug phonon qimageblitz qscintilla qwt webkit"
+
+RDEPEND="
+ >=dev-lang/perl-5.10.1
+ $(add_kdebase_dep smokeqt 'declarative?,multimedia?,opengl?,phonon?,qimageblitz?,qscintilla?,qthelp?,qwt?,webkit?')
+"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/List-MoreUtils )
+"
+
+# Split from kdebindings-perl in 4.7
+add_blocker kdebindings-perl
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_disable qwt)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}