summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit069ac1542ef075cd556dfbb8d0e420eae342dc39 (patch)
tree1dd564f7adb4f21ca4525760daf1f3d100ef29ae /kde-base/qyoto/qyoto-4.8.4.ebuild
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadhistorical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.gz
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.tar.bz2
historical-069ac1542ef075cd556dfbb8d0e420eae342dc39.zip
KDE 4.8.4 version bump
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/qyoto/qyoto-4.8.4.ebuild')
-rw-r--r--kde-base/qyoto/qyoto-4.8.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/qyoto/qyoto-4.8.4.ebuild b/kde-base/qyoto/qyoto-4.8.4.ebuild
new file mode 100644
index 000000000000..81cf163a3018
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.8.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.8.4.ebuild,v 1.1 2012/06/21 21:54:36 dilfridge Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}