summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 01:57:44 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-01-18 01:57:44 +0000
commit8d83eaaf8cd7a88235f60ff0642035944fba63f3 (patch)
treed44ac6704495d126b80e8222225d657e677dbd3f /kde-base/solid/solid-4.0.0.ebuild
parentAdded KDE 4.0.0's secpolicy. (diff)
downloadhistorical-8d83eaaf8cd7a88235f60ff0642035944fba63f3.tar.gz
historical-8d83eaaf8cd7a88235f60ff0642035944fba63f3.tar.bz2
historical-8d83eaaf8cd7a88235f60ff0642035944fba63f3.zip
Added KDE 4.0.0's solid.
Package-Manager: portage-2.1.4
Diffstat (limited to 'kde-base/solid/solid-4.0.0.ebuild')
-rw-r--r--kde-base/solid/solid-4.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/solid/solid-4.0.0.ebuild b/kde-base/solid/solid-4.0.0.ebuild
new file mode 100644
index 000000000000..18240ababc0b
--- /dev/null
+++ b/kde-base/solid/solid-4.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.0.0.ebuild,v 1.1 2008/01/18 01:57:43 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth networkmanager test"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ >=sys-apps/hal-0.5.9
+ bluetooth? ( net-wireless/bluez-libs )
+ networkmanager? ( =net-misc/networkmanager-0.6* )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="libs/solid/"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)"
+
+ kde4-meta_src_compile
+}