summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/solid
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.2.4.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index 578bdfe4dda5..260892926bd8 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.29 2009/06/03 18:28:54 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.30 2009/06/04 13:52:54 alexxy Exp $
+
+*solid-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -solid-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/solid/solid-4.2.4.ebuild b/kde-base/solid/solid-4.2.4.ebuild
new file mode 100644
index 000000000000..e1905113ca97
--- /dev/null
+++ b/kde-base/solid/solid-4.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.2.4.ebuild,v 1.1 2009/06/04 13:52:54 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-4.2.0-backport-solid-bluetooth.patch.tar.bz2"
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="bluetooth debug networkmanager"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ >=sys-apps/hal-0.5.9
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=( "${DISTDIR}/${PN}-4.2.0-backport-solid-bluetooth.patch.tar.bz2" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)"
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ elog "If you want to be notified about new plugged devices by a popup,"
+ elog "install kde-base/soliduiserver"
+
+ kde4-meta_pkg_postinst
+}