summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commit6e9827de00edc0bb0a6fe077b16b9694ac2726f5 (patch)
treea0314490ab642a367b0f8019fb62003898871e78 /kde-base/step
parentKeyword ~ppc64 wrt #337385 (diff)
downloadhistorical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.gz
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.bz2
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.zip
KDE SC 4.5.3 Version bump
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.5.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 4380f34a6cc5..d13f36da266b 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.62 2010/10/06 09:17:32 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.63 2010/11/03 16:30:41 scarabeus Exp $
+
+*step-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> +step-4.5.3.ebuild:
+ Version bump
*step-4.5.2 (05 Oct 2010)
diff --git a/kde-base/step/step-4.5.3.ebuild b/kde-base/step/step-4.5.3.ebuild
new file mode 100644
index 000000000000..c064e4870f1f
--- /dev/null
+++ b/kde-base/step/step-4.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.5.3.ebuild,v 1.1 2010/11/03 16:30:41 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gsl +qalculate"
+
+DEPEND="
+ >=dev-cpp/eigen-2.0.3:2
+ sci-libs/cln
+ >=sci-mathematics/gmm-3.0
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with qalculate)
+ )
+
+ kde4-meta_src_configure
+}